summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2021-09-04 22:19:00 +0300
committerStefan Strogin <steils@gentoo.org>2021-09-04 19:19:45 +0000
commit54a85dc02ea24b8cd262be21451e145735e217a5 (patch)
treeb76b3e084f2d303e8540ffb14bfe95aec9024e94 /media-video
parentmedia-libs/libopenshot: upgrade to 0.2.6 (diff)
downloadgentoo-54a85dc02ea24b8cd262be21451e145735e217a5.tar.gz
gentoo-54a85dc02ea24b8cd262be21451e145735e217a5.tar.bz2
gentoo-54a85dc02ea24b8cd262be21451e145735e217a5.zip
media-video/openshot: upgrade to 2.6.0
Closes: https://bugs.gentoo.org/810484 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/openshot/Manifest1
-rw-r--r--media-video/openshot/openshot-2.6.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
index 39cbf60fcec2..0f2d2af3aba6 100644
--- a/media-video/openshot/Manifest
+++ b/media-video/openshot/Manifest
@@ -1,2 +1,3 @@
DIST openshot-2.5.1.tar.gz 60217543 BLAKE2B 3f195b14a9fb004e845c731be64138c20da84ac0c90db43b547ee9ea059d32f85ada04aa0462b755a7ea5c3d3b30088fab35414147dded55deb9d5eab5926d2d SHA512 8254a45254bbe523b6485b9598022de2c46ec30818e606ac4665790d29486693c4efe9f5bc55ee43d6342de6782cf0090e4bc880e831c08e3b1218bca555af14
DIST openshot-2.5.1_p20210228.tar.gz 64780534 BLAKE2B c31bd2531df28ce9bed688fbc34dc383018024ffe9364699e45c08135f5c0692d97f601bc578ba07fd44e2f8f58f0b27c5bc10bb3af48c8cf0be17a45b966116 SHA512 b5ce39d31bc1b997d272b3817ccdcef4749126755e329a278700f6735a1484b0c2b917e04a5f1b9826ee0e5ea983a624be59af16bf79f038be44a29763cc68b5
+DIST openshot-2.6.0.tar.gz 68096356 BLAKE2B e34ef6ee043565a895a110f867bbdbe4f49290d883224eec1c710f7b94186cea3a5083502b5c80d2dc02ddd61fc87d0ceacd397465892bd5e149b1846a2328ef SHA512 9e569f318672047e8251d00ce0bb80e4b295d5daba58c11a3e286b7daebf45b35a34d4ecc5a9d81891b0a68d75d813a78023ee984b8690a2d1217a8517239ee9
diff --git a/media-video/openshot/openshot-2.6.0.ebuild b/media-video/openshot/openshot-2.6.0.ebuild
new file mode 100644
index 000000000000..9add97810814
--- /dev/null
+++ b/media-video/openshot/openshot-2.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE=xml
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg
+
+MY_PN="${PN}-qt"
+
+DESCRIPTION="Award-winning free and open-source video editor"
+HOMEPAGE="https://openshot.org/"
+SRC_URI="https://github.com/OpenShot/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,svg,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyzmq[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=media-libs/libopenshot-0.2.6:0=[python,${PYTHON_SINGLE_USEDEP}]"
+DEPEND=""
+BDEPEND="$(python_gen_cond_dep '
+ doc? ( dev-python/sphinx[${PYTHON_MULTI_USEDEP}] )
+ ')"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # prevent setup.py from trying to update MIME databases
+ sed -i 's/^ROOT =.*/ROOT = False/' setup.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" src/tests/query_tests.py -v --platform minimal || die
+}