summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-24 00:05:31 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-24 01:00:10 +0200
commit5e65f7f17e9de39391fa669622039ff6c759abf9 (patch)
tree6c47fab201fe1728aa2247efec7f85fcd36fee9f /media-video
parentmedia-sound/gnome-sound-recorder: cleanup old revision (diff)
downloadgentoo-5e65f7f17e9de39391fa669622039ff6c759abf9.tar.gz
gentoo-5e65f7f17e9de39391fa669622039ff6c759abf9.tar.bz2
gentoo-5e65f7f17e9de39391fa669622039ff6c759abf9.zip
media-video/cheese: version bump 3.20.2 → 3.22.1
Package-Manager: portage-2.3.1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-3.22.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index fc9b351e7cc9..3517485ebc8d 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1,2 +1,3 @@
DIST cheese-3.18.1.tar.xz 1829408 SHA256 fc9d8798b1f0c6b35731f063869a32c6910bab6d0386b9ea36386ebda0d57177 SHA512 37e48f393521b242750d0cbda31537564cd63d2ceb4b3ea6a066c758c8bc9ac632dcbe4ee0ec0b36405c54058ea98ff5744ed087bf928445ffa58fdd2b04d2f7 WHIRLPOOL b996dcfb5f4d3ab72811d7f072dc16d7c0c17109664ce84581659d70786585738b169949f4c9fe2f72df8b48401a30fde96c2557f2a1d888d7bafd38f5de2fef
DIST cheese-3.20.2.tar.xz 1843696 SHA256 b7c18719b708e039c063ef09278ee813923556e06af4a7e9598c5d3bdeb83775 SHA512 d903ff1d8c7ed728d252dbafbbd73567bb885456b0ae078b68ce605e174d88258d93475019a20caeb653c6f045cd94a4234dd17e50fa958cfb4e9d6ab3096b0e WHIRLPOOL 5fdd4a9f995925e597ca538f2434416f7392e1a30e5174b5f6781809032abd1dac6f7191830c99d159d371029c0ef6ad3b740c3f16046e204abe575c708192d3
+DIST cheese-3.22.1.tar.xz 1843092 SHA256 34353d19134da0041343b90ba737ec758bb5d1e23bd6e985c66b7e15f5313ae9 SHA512 193e421a0310a60871b8e0ac7ac28c16b7ed1caf0869904f803f45c4b15be74ab98dd88df54e5ce8c0885f466004d182450350295d3d89264e6f39035a389656 WHIRLPOOL 41c140122fb7b01b8bcaea155381b1bbabc016298b19f43645b37f881903d9f5f0399e01baff1c7a215d3949b7804e22785d048c6504539855966f21651837b8
diff --git a/media-video/cheese/cheese-3.22.1.ebuild b/media-video/cheese/cheese-3.22.1.ebuild
new file mode 100644
index 000000000000..d1327b383793
--- /dev/null
+++ b/media-video/cheese/cheese-3.22.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ virtx emake check
+}