summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2015-09-15 15:21:25 +0200
committerLuca Barbato <lu_zero@gentoo.org>2015-09-25 12:08:27 +0200
commit644e0b3952fd1fc4bce3b9315fb95c7dc9283cfa (patch)
tree8bf0d92e2a2361eccac894b642f68f3eb8c54c35 /media-video
parentdev-python/pyquery: Drop optional dep to optfeature (diff)
downloadgentoo-644e0b3952fd1fc4bce3b9315fb95c7dc9283cfa.tar.gz
gentoo-644e0b3952fd1fc4bce3b9315fb95c7dc9283cfa.tar.bz2
gentoo-644e0b3952fd1fc4bce3b9315fb95c7dc9283cfa.zip
libav: Filter -marm
It is know to cause horrible problems.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libav/libav-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/media-video/libav/libav-9999.ebuild b/media-video/libav/libav-9999.ebuild
index 503d6e6a4707..09447dad547f 100644
--- a/media-video/libav/libav-9999.ebuild
+++ b/media-video/libav/libav-9999.ebuild
@@ -276,6 +276,11 @@ multilib_src_configure() {
# Misc stuff
use hardcoded-tables && myconf+=( --enable-hardcoded-tables )
+ # Forcing arm would make the compiler break left and right
+ if [[ ${ABI} == arm ]]; then
+ filter-flags -marm
+ fi
+
# Specific workarounds for too-few-registers arch...
if [[ ${ABI} == x86 ]]; then
local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}