summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristoffer Pouls <kristoffer@pouls.me>2022-01-13 21:01:57 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-02-11 16:56:48 +0200
commit6bf73beb5bddcd96eaef2ca251d8e7b6d5969abb (patch)
treea3cb2c60a32ee0927ac0bad065b7df5a54425563 /media-video
parentapp-office/homebank: remove old version (diff)
downloadgentoo-6bf73beb5bddcd96eaef2ca251d8e7b6d5969abb.tar.gz
gentoo-6bf73beb5bddcd96eaef2ca251d8e7b6d5969abb.tar.bz2
gentoo-6bf73beb5bddcd96eaef2ca251d8e7b6d5969abb.zip
media-video/shotcut: bump to 21.12.24
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/shotcut/Manifest2
-rw-r--r--media-video/shotcut/shotcut-21.12.24.ebuild66
2 files changed, 67 insertions, 1 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index 8c71ff273cd8..be69ec8539cc 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1,2 +1,2 @@
-DIST shotcut-21.09.20.tar.gz 4358591 BLAKE2B 3919cb0f5c3f0aaa665729227d077cdeac1569102509bbf6be7f9451cadda8e22b38a8e796ef5fd2f5dd84bff2abbd98103a0917eb9acacdc9db771968f723ef SHA512 6c2463c8d81c4e61b59d97ba2ee8f9aba5c420ee50b6c46c0e5f1c177e44cea6bc1fab5a7184ce8b13d2818b207efffe3c12f4d1682ce002279ba16c1c9bd624
DIST shotcut-21.10.31.tar.gz 4408987 BLAKE2B 88c77503475de21a4989d0e412a214c2d5c2c30d60abf11e06326a599e14c4b1a7d7b678c494d13223cf7e11c6dd12c810e7d112750f4f18308250693316a8cd SHA512 de5d9992a41217323b3d96cc7618ed5adc633e7d0e65b6f8f189405008f6faba011a80f38cda0126b18ab28a359f6784078cb298b2ee29dcdfdc6769963714f3
+DIST shotcut-21.12.24.tar.gz 4522616 BLAKE2B 3d6f423e888971f8913b0fa0d21fd0b122f941840b871275cd7c56e747c5637ecef56b2111b0c7be953bb71013aee66361202aea74e9d1ffe4028d07580815c0 SHA512 4173a2772cc5dcb62f113301aca7c3e0d1c32985b235e38f6c0bc17e0fdad88443123efb71d9fd4d97366d95500ce41776d4d8b1e214fc4c421219185fe112f4
diff --git a/media-video/shotcut/shotcut-21.12.24.ebuild b/media-video/shotcut/shotcut-21.12.24.ebuild
new file mode 100644
index 000000000000..0f1a45e08825
--- /dev/null
+++ b/media-video/shotcut/shotcut-21.12.24.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+IUSE="debug"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-7.0.1[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
+ media-video/ffmpeg
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5
+ virtual/jack
+"
+
+src_configure() {
+ local myqmakeargs=(
+ PREFIX="${EPREFIX}/usr"
+ SHOTCUT_VERSION="${PV}"
+ DEFINES+=SHOTCUT_NOUPGRADE
+ )
+ use debug || myqmakeargs+=(DEFINES+=NDEBUG)
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}