summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-01-28 19:35:52 +0300
committerDavid Seifert <soap@gentoo.org>2017-01-29 23:53:16 +0100
commit6d6adc6f7ab3c4d727d84669a01e56608a7cae86 (patch)
tree4197cea82c499983b972bc8d39401f2530c5aea2 /media-video
parentmedia-video/mpv: adjust opengl USE constraints in 9999 (diff)
downloadgentoo-6d6adc6f7ab3c4d727d84669a01e56608a7cae86.tar.gz
gentoo-6d6adc6f7ab3c4d727d84669a01e56608a7cae86.tar.bz2
gentoo-6d6adc6f7ab3c4d727d84669a01e56608a7cae86.zip
media-video/mpv: enforce proper pkg-config in 9999
Export PKG_CONFIG. Otherwise mpv uses waf machinery to basically do $(which pkg-config) and then uses the result. This command is probably harmless in most cases, but it breaks cross-compilation entirely as compiler arguments are polluted with flags like '-L/usr/lib', which breaks e.g. linking. Export also CC and AR. This works fine now, but leave no chances to get screwed by waf. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3718
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-9999.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index ee0b6c629a5f..01279532d659 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -167,6 +167,8 @@ src_prepare() {
}
src_configure() {
+ tc-export CC PKG_CONFIG AR
+
local mywafargs=(
--confdir="${EPREFIX}/etc/${PN}"
--docdir="${EPREFIX}/usr/share/doc/${PF}"