summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-21 13:14:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-21 13:19:16 +0100
commit76aa678ba474b0bae6921ef02e845c017ed96f00 (patch)
treeadb9c72316722af6536dfb7bf144c731e6307287 /media-video
parentmedia-video/mkvtoolnix: simplify configure options with qt5_get_bindir (diff)
downloadgentoo-76aa678ba474b0bae6921ef02e845c017ed96f00.tar.gz
gentoo-76aa678ba474b0bae6921ef02e845c017ed96f00.tar.bz2
gentoo-76aa678ba474b0bae6921ef02e845c017ed96f00.zip
media-video/mkvtoolnix: Sync 20.0.0 ebuild with live ebuild.
Closes: https://bugs.gentoo.org/643328 Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mkvtoolnix/mkvtoolnix-20.0.0.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/media-video/mkvtoolnix/mkvtoolnix-20.0.0.ebuild b/media-video/mkvtoolnix/mkvtoolnix-20.0.0.ebuild
index 97ffe1246988..745644a6e294 100644
--- a/media-video/mkvtoolnix/mkvtoolnix-20.0.0.ebuild
+++ b/media-video/mkvtoolnix/mkvtoolnix-20.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs versionator multiprocessing
+inherit toolchain-funcs versionator multiprocessing xdg-utils qmake-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/mbunkus/mkvtoolnix.git"
@@ -52,8 +52,6 @@ DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )
"
-DOCS="AUTHORS NEWS.md README.md"
-
pkg_pretend() {
# https://bugs.gentoo.org/419257
local ver=4.6
@@ -75,10 +73,10 @@ src_configure() {
if use qt5 ; then
# ac/qt5.m4 finds default Qt version set by qtchooser, bug #532600
myconf+=(
- --with-moc=/usr/$(get_libdir)/qt5/bin/moc
- --with-uic=/usr/$(get_libdir)/qt5/bin/uic
- --with-rcc=/usr/$(get_libdir)/qt5/bin/rcc
- --with-qmake=/usr/$(get_libdir)/qt5/bin/qmake
+ --with-moc=$(qt5_get_bindir)/moc
+ --with-uic=$(qt5_get_bindir)/uic
+ --with-rcc=$(qt5_get_bindir)/rcc
+ --with-qmake=$(qt5_get_bindir)/qmake
)
fi
@@ -109,3 +107,13 @@ src_install() {
einstalldocs
doman doc/man/*.1
}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}