summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-17 20:45:42 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-17 20:45:42 +0100
commit7cc00ed38e59e6f00f4f122d1ec8e69a72945587 (patch)
tree54bc6c8bc55fb1a6ad848fb133fe439682d07c8c /media-video
parentmedia-sound/sound-juicer: Drop old (diff)
downloadgentoo-7cc00ed38e59e6f00f4f122d1ec8e69a72945587.tar.gz
gentoo-7cc00ed38e59e6f00f4f122d1ec8e69a72945587.tar.bz2
gentoo-7cc00ed38e59e6f00f4f122d1ec8e69a72945587.zip
media-video/cheese: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-3.18.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index dee6b3f268a4..d9fc402539dd 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1,3 +1,4 @@
DIST cheese-3.12.2.tar.xz 1777924 SHA256 a7b45369e75e222e3bd5e9a4408a0e6c230be0c49d359a387d36a42e17e3bc64 SHA512 4548ac903cc435f8ab5e55fbf684239d9a8da2413448506a1bfd6a387348e9b8b08dc3f292e8eff5bab3491ff079cadcb901f82fd42dadd75b801e154a15cdf3 WHIRLPOOL a8312e428771059cbdc982e458bb119af507e2a667f2af9743cdfe2ed6a25829432e7ea7a5dca27932999b7f3ab1cf16f99a0b31cec8f9094fd9941b85b57dfb
DIST cheese-3.14.2.tar.xz 1804900 SHA256 3074a567e0080d7b8fc0512bf3b08c3397e38083cce1767104624288f033a517 SHA512 cf89baab6858bd2fa100e4dec24067d0bcc49f27632331b99a4f442f235ffca14630af2bf11317cbdc3850202c71bab1920101b9190091c2f0ff9bd4274c0753 WHIRLPOOL 7c909d3d991d97b674a0edd48e639e11d1c81eb9b938861c6f5555f722785f1f9c5b6a74ca79820d6c7bb24ba159154fc402a19248dcadcc1e3aea444b11bc4e
DIST cheese-3.16.1.tar.xz 1823864 SHA256 44622f6ad6d8703b22c6d40219ae317959495ccc9994b563b324592933ff90a0 SHA512 c5af1fb76b53e8f1331f5e30052c05f5555eb6baf1c6e0a3b63c962e99507c83240175b5e1d84817425a34f0f1ebd3c51ea126799873390685f61ae4a7add043 WHIRLPOOL 901cd41f7923d456f7f7f78ac248014e9223eba41e3560e3198c160250b9c148bb1c35dd2c22df6560b97c30a2ba278c54dbc626b752100de473561bd1e77785
+DIST cheese-3.18.1.tar.xz 1829408 SHA256 fc9d8798b1f0c6b35731f063869a32c6910bab6d0386b9ea36386ebda0d57177 SHA512 37e48f393521b242750d0cbda31537564cd63d2ceb4b3ea6a066c758c8bc9ac632dcbe4ee0ec0b36405c54058ea98ff5744ed087bf928445ffa58fdd2b04d2f7 WHIRLPOOL b996dcfb5f4d3ab72811d7f072dc16d7c0c17109664ce84581659d70786585738b169949f4c9fe2f72df8b48401a30fde96c2557f2a1d888d7bafd38f5de2fef
diff --git a/media-video/cheese/cheese-3.18.1.ebuild b/media-video/cheese/cheese-3.18.1.ebuild
new file mode 100644
index 000000000000..e6882c65737a
--- /dev/null
+++ b/media-video/cheese/cheese-3.18.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+
+# using clutter-gst-2.0.0 results in GLSL errors; bug #478702
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ virtual/libgudev:=
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ media-libs/gst-plugins-good:1.0
+
+ media-plugins/gst-plugins-jpeg:1.0
+ media-plugins/gst-plugins-v4l2:1.0
+ media-plugins/gst-plugins-vpx:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_compile() {
+ # Clutter-related sandbox violations when USE="doc introspection" and
+ # FEATURES="-userpriv" (see bug #385917).
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ Xemake check
+}