summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-03 17:35:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-03 17:35:05 +0100
commit868c21bc29243d315cec9791bb0d19439a97414b (patch)
tree473981f82ca0904247dc6d29c23e48e84ca8f6e8 /media-video
parentdev-ml/ocaml-expat: bump to 1.0.0 (diff)
downloadgentoo-868c21bc29243d315cec9791bb0d19439a97414b.tar.gz
gentoo-868c21bc29243d315cec9791bb0d19439a97414b.tar.bz2
gentoo-868c21bc29243d315cec9791bb0d19439a97414b.zip
media-video/dvdauthor: bump to 0.7.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdauthor/Manifest1
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-video/dvdauthor/Manifest b/media-video/dvdauthor/Manifest
index 61dcf35bf0b8..bc66b13ab7ca 100644
--- a/media-video/dvdauthor/Manifest
+++ b/media-video/dvdauthor/Manifest
@@ -1 +1,2 @@
DIST dvdauthor-0.7.1.tar.gz 421324 SHA256 501fb11b09c6eb9c5a229dcb400bd81e408cc78d34eab6749970685023c51fe9 SHA512 0875300df4711bf5758cb8a3ec03793689abd403cdebfc5736463d9b6df49a22e66e9e1f0c2abfcb7d25469c2e7f7e76789f7779cc0743ec972f8965b0f744a9 WHIRLPOOL c07526bbdbd75b4ddc0f2a1057f2bf27dbb5c63b4e4495b3a051d530af58ba4d4d75ec15dff2e3628cd1cb46b476ecb6a3d640ec30e1e6692d832549108b3e63
+DIST dvdauthor-0.7.2.tar.gz 648305 SHA256 3020a92de9f78eb36f48b6f22d5a001c47107826634a785a62dfcd080f612eb7 SHA512 202b8bba38939d122dc864921a57e89906ca99ddabf44e3b07419cc42cc052567cd892b41f1171c9c195c9a770758e9319a942ea64d14ee8fa847588c7761125 WHIRLPOOL d74d9b9d7976c5b98c9c6ebae5f5af5c201bc93f295c400b8cf7a10d4012e9b602f7817dd4acca70578a347d38fbe5bf43bbe8df398b4bc38c20bcc165ee1c3c
diff --git a/media-video/dvdauthor/dvdauthor-0.7.2.ebuild b/media-video/dvdauthor/dvdauthor-0.7.2.ebuild
new file mode 100644
index 000000000000..a957dcc1d15b
--- /dev/null
+++ b/media-video/dvdauthor/dvdauthor-0.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools for generating DVD files to be played on standalone DVD players"
+HOMEPAGE="http://dvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="graphicsmagick"
+
+RDEPEND=">=dev-libs/fribidi-0.19.2
+ dev-libs/libxml2
+ >=media-libs/freetype-2
+ media-libs/libdvdread
+ media-libs/libpng:0=
+ graphicsmagick? ( media-gfx/graphicsmagick )
+ !graphicsmagick? ( >=media-gfx/imagemagick-5.5.7.14:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ default
+ if use graphicsmagick ; then
+ sed -i -e 's:ExportImagePixels:dIsAbLeAuToMaGiC&:' configure \
+ || die
+ fi
+}
+
+src_configure() {
+ use graphicsmagick && \
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags GraphicsMagick)" #459976
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)" #417041
+ econf
+}