summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-01-28 19:43:08 +0300
committerDavid Seifert <soap@gentoo.org>2017-01-29 23:53:17 +0100
commit87fa687b4bda308e2039f5ac534109c502a1201e (patch)
tree8b70f7795c1e65b46d03bd2c7cf80aff5c784c2a /media-video
parentmedia-video/mpv: require only virtual/opengl for raspberry-pi in 9999 (diff)
downloadgentoo-87fa687b4bda308e2039f5ac534109c502a1201e.tar.gz
gentoo-87fa687b4bda308e2039f5ac534109c502a1201e.tar.bz2
gentoo-87fa687b4bda308e2039f5ac534109c502a1201e.zip
media-video/mpv: disable broken cross-builds with raspberry-pi in 9999
Upstream now uses pkg-config to determine raspberry-pi compiler flags instead of hardcoding them. Update the ebuild accordingly. This is nice, but Gentoo tools are broken and don't work as advertised, see Gentoo bug 607344. Thus, disable cross-builds with raspberry-pi for now. The required bits are in ebuild, so power users can workaround it. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3718
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 8e33c3e35e4a..7d21765d19a7 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -169,6 +169,12 @@ src_prepare() {
src_configure() {
tc-export CC PKG_CONFIG AR
+ if tc-is-cross-compiler && use raspberry-pi; then
+ export EXTRA_PKG_CONFIG_LIBDIR="${SYSROOT%/}${EPREFIX}/opt/vc/lib/pkgconfig"
+ # Drop next line when Gentoo bug 607344 is fixed or if you fixed it locally.
+ die "${PN} can't be cross built with raspberry-pi USE enabled. See Gentoo bug 607344."
+ fi
+
local mywafargs=(
--confdir="${EPREFIX}/etc/${PN}"
--docdir="${EPREFIX}/usr/share/doc/${PF}"