summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-11-01 21:43:01 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-11-01 21:43:01 +0000
commit920b09417a7fa5e97686252bcc475f6095f312a2 (patch)
treecec64c36e7a3b7ff4fca3dfd277fea039ffacc05 /media-video
parentdev-lang/rust: modify QA_WX paths (diff)
downloadgentoo-920b09417a7fa5e97686252bcc475f6095f312a2.tar.gz
gentoo-920b09417a7fa5e97686252bcc475f6095f312a2.tar.bz2
gentoo-920b09417a7fa5e97686252bcc475f6095f312a2.zip
media-video/makemkv: Version bump to 1.16.5, EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/makemkv/Manifest2
-rw-r--r--media-video/makemkv/makemkv-1.16.5.ebuild126
2 files changed, 128 insertions, 0 deletions
diff --git a/media-video/makemkv/Manifest b/media-video/makemkv/Manifest
index 6659e450f4a3..d0d8cd97cc71 100644
--- a/media-video/makemkv/Manifest
+++ b/media-video/makemkv/Manifest
@@ -1,2 +1,4 @@
DIST makemkv-bin-1.16.4.tar.gz 15455839 BLAKE2B 5d29416beeb06f5fc66db39e5323de4d3491b120ec1b734183c9aaf937baf8a63a277ddb378b668d9659c34449c474e2ab9a7bb82a448f33de85abf82e5e791b SHA512 d2d12a18ef64e77d7a47e1e68ced265fbd2071fd60fb8118085c2b8c892132e9ef81f1a54c09e5f45be6f880a91cef3bb25ed5e86e3735f5b449c6b7fb88a72f
+DIST makemkv-bin-1.16.5.tar.gz 15585124 BLAKE2B c006b47af571089de5a3283f0f4094556b3fbd9b67d26f7fc57e05e6feb0b3a6875742d8eb5536c561dbd8e6914b9255e38b97eb0b9acaba761daa28e532c3af SHA512 4e0ee2f2d9036a46dc3d3bdf13048c17f7efe886ddf808911d7694c319b0b887439907a0d5f47a7ff3824ef7bfb036d5900a66d3f500dc1b57223012479a0609
DIST makemkv-oss-1.16.4.tar.gz 6536730 BLAKE2B 8f5167c6b5056f9ea38a47b60875aac8394c130b40f08ef7a102f00937c34feb58e6436a9140509da9fc2d2b835956dede6bd8485827f3037b2026b0421a7094 SHA512 e25b41cbc348a49f13914af6b2dd040376c7517273dd4f49dc68fe9e363e28e336fb6d3d525b190c11d70e7c9b7127ffabdd89b3130cd1aab55a6a6f708d7452
+DIST makemkv-oss-1.16.5.tar.gz 6541723 BLAKE2B e628fa65a883e69b51a84bdc0d46da5628c1981017f2e64a31e36e3b7bc45e16d2a94831a6e0fd405676d8385ce11afb9db7d5fc81f2cb174e9ca44dde775f1d SHA512 865f621fb326541dcc05231667510895cb20e3bccb4705d67533aefec57b043d6fd33f0541290428f45226123f2dc419f7d0f2c071518f6f7a548c5aeea8978e
diff --git a/media-video/makemkv/makemkv-1.16.5.ebuild b/media-video/makemkv/makemkv-1.16.5.ebuild
new file mode 100644
index 000000000000..23a32955e746
--- /dev/null
+++ b/media-video/makemkv/makemkv-1.16.5.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic linux-info xdg
+
+MY_P=makemkv-oss-${PV}
+MY_PB=makemkv-bin-${PV}
+
+DESCRIPTION="Tool for ripping and streaming Blu-ray, HD-DVD and DVD discs"
+HOMEPAGE="http://www.makemkv.com/"
+SRC_URI="http://www.makemkv.com/download/${MY_P}.tar.gz
+ http://www.makemkv.com/download/${MY_PB}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui +java"
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="usr/bin/makemkvcon usr/bin/mmdtsdec"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/openssl:0=[-bindist(-)]
+ >=media-video/ffmpeg-1.0.0:0=
+ sys-libs/glibc
+ sys-libs/zlib
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ net-misc/wget
+ java? ( >=virtual/jre-1.8 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ gui? ( dev-qt/qtcore:5 )
+"
+
+CONFIG_CHECK="~CHR_DEV_SG"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-path.patch
+ "${FILESDIR}"/${PN}-flags.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use java; then
+ rm -v "${WORKDIR}/${MY_PB}"/src/share/blues.* || die
+ fi
+}
+
+src_configure() {
+ # See bug #439380.
+ replace-flags -O* -Os
+
+ econf \
+ --enable-debug \
+ --disable-noec \
+ $(use_enable gui) \
+ $(use_enable gui qt5)
+}
+
+src_install() {
+ local myarch
+ case "${ARCH}" in
+ arm) myarch=armel ;;
+ x86) myarch=i386 ;;
+ *) myarch=${ARCH} ;;
+ esac
+
+ default
+
+ # add missing symlinks for QA
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
+
+ cd "${WORKDIR}"/${MY_PB} || die
+
+ # install prebuilt bin
+ dobin bin/"${myarch}"/makemkvcon
+
+ # additional tool is actually part of makemkvcon
+ dosym makemkvcon /usr/bin/sdftool
+
+ # install profiles and locales
+ insinto /usr/share/MakeMKV
+ doins src/share/*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "While MakeMKV is in beta mode, upstream has provided a license"
+ elog "to use if you do not want to purchase one."
+ elog ""
+ elog "See this forum thread for more information, including the key:"
+ elog "https://www.makemkv.com/forum/viewtopic.php?f=5&t=1053"
+ elog ""
+ elog "Note that beta license may have an expiration date and you will"
+ elog "need to check for newer licenses/releases. "
+ elog ""
+ elog "We previously said to copy default.mmcp.xml to ~/.MakeMKV/. This"
+ elog "is no longer necessary and you should delete it from there to"
+ elog "avoid warning messages."
+ elog ""
+ elog "MakeMKV can also act as a drop-in replacement for libaacs and"
+ elog "libbdplus, allowing transparent decryption of a wider range of"
+ elog "titles under players like VLC and mplayer. To enable this, set"
+ elog "the following variables when launching the player:"
+ elog "LIBAACS_PATH=libmmbd LIBBDPLUS_PATH=libmmbd"
+}