summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 23:10:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 23:10:11 +0100
commitb0d93f19dd63cf0dd6f9154ef33ef8326e3c7872 (patch)
tree2def691858836e396a93adbecf499c3398420722 /media-video
parentsci-geosciences/qgis: Fix Qt5LinguistTools detection (for lrelease) (diff)
downloadgentoo-b0d93f19dd63cf0dd6f9154ef33ef8326e3c7872.tar.gz
gentoo-b0d93f19dd63cf0dd6f9154ef33ef8326e3c7872.tar.bz2
gentoo-b0d93f19dd63cf0dd6f9154ef33ef8326e3c7872.zip
media-video/simplescreenrecorder: Fix Qt5LinguistTools detection, BDEPEND
See also: https://github.com/MaartenBaert/ssr/pull/614 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.2-cmake.patch28
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.4.2.ebuild7
2 files changed, 32 insertions, 3 deletions
diff --git a/media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.2-cmake.patch b/media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.2-cmake.patch
new file mode 100644
index 000000000000..9f8bc408331e
--- /dev/null
+++ b/media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.2-cmake.patch
@@ -0,0 +1,28 @@
+From 5330a3d65b7877f5f3691c20df35fbb7856d6f38 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu, 11 Jan 2018 21:28:15 +0100
+Subject: [PATCH] Fix Qt5LinguistTools detection/lrelease binary location
+
+Correctly find the Qt5 module that provides the path to Qt5-based lrelease.
+Available since >= Qt-5.3.1 which is well below the current minimum version.
+---
+ src/translations/CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/translations/CMakeLists.txt b/src/translations/CMakeLists.txt
+index d9afded..174acea 100644
+--- a/src/translations/CMakeLists.txt
++++ b/src/translations/CMakeLists.txt
+@@ -1,7 +1,8 @@
+ # translations for 'simplescreenrecorder' executable
+
+ if(WITH_QT5)
+- find_program(LRELEASE NAMES lrelease-qt5 lrelease)
++ find_package(Qt5LinguistTools REQUIRED)
++ set(LRELEASE Qt5::lrelease)
+ else()
+ find_program(LRELEASE NAMES lrelease-qt4 lrelease)
+ endif()
+--
+2.29.2
+
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.2.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.2.ebuild
index 9fb007c901bd..0a27ef778b0a 100644
--- a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.2.ebuild
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.2.ebuild
@@ -40,9 +40,10 @@ RDEPEND="
jack? ( virtual/jack )
pulseaudio? ( media-sound/pulseaudio )
"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
pkg_pretend() {
if [[ "${ABI}" == amd64 ]]; then