summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-03 17:41:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-03 17:45:39 +0200
commitc71e13b8f81d5be04ad3cfc642449cd7c4867ce0 (patch)
treea6ee03507534fa2fc8ecba1f2d3b2a230da54f01 /media-video
parentmedia-video/aravis: Bump to eapi 6 (diff)
downloadgentoo-c71e13b8f81d5be04ad3cfc642449cd7c4867ce0.tar.gz
gentoo-c71e13b8f81d5be04ad3cfc642449cd7c4867ce0.tar.bz2
gentoo-c71e13b8f81d5be04ad3cfc642449cd7c4867ce0.zip
media-video/aravis: EAPI-7 bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-video')
-rw-r--r--media-video/aravis/aravis-0.5.10.ebuild25
-rw-r--r--media-video/aravis/aravis-9999.ebuild46
2 files changed, 33 insertions, 38 deletions
diff --git a/media-video/aravis/aravis-0.5.10.ebuild b/media-video/aravis/aravis-0.5.10.ebuild
index eb90789b01aa..ed18bd2b6343 100644
--- a/media-video/aravis/aravis-0.5.10.ebuild
+++ b/media-video/aravis/aravis-0.5.10.ebuild
@@ -1,17 +1,14 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit versionator
-
-KEYWORDS="~amd64"
-
-if [[ ${PV} == "9999" ]]; then
- KEYWORDS=""
- EGIT_REPO_URI="git://git.gnome.org/aravis"
- EGIT_COMMIT="${aravis_LIVE_COMMIT:-master}"
- inherit git-2 autotools
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/AravisProject/aravis.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Library for video acquisition using Genicam cameras"
@@ -19,7 +16,6 @@ HOMEPAGE="https://live.gnome.org/Aravis"
LICENSE="LGPL-2.1"
SLOT="0"
-
IUSE="X gstreamer caps"
GST_DEPEND="media-libs/gstreamer:1.0
@@ -42,14 +38,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
dev-libs/gobject-introspection"
-if [[ -z ${EGIT_COMMIT} ]]; then
- SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.xz"
-else
+if [[ ${PV} != *9999 ]]; then
DEPEND+=" dev-util/gtk-doc dev-util/intltool"
fi
src_prepare() {
- if [[ -n ${EGIT_COMMIT} ]]; then
+ default
+ if [[ ${PV} = *9999 ]]; then
intltoolize || die
gtkdocize || die
eautoreconf
diff --git a/media-video/aravis/aravis-9999.ebuild b/media-video/aravis/aravis-9999.ebuild
index 5d0d72cf0220..ed18bd2b6343 100644
--- a/media-video/aravis/aravis-9999.ebuild
+++ b/media-video/aravis/aravis-9999.ebuild
@@ -1,17 +1,14 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit versionator
-
-KEYWORDS="~amd64"
-
-if [[ ${PV} == "9999" ]]; then
- KEYWORDS=""
- EGIT_REPO_URI="git://git.gnome.org/aravis"
- EGIT_COMMIT="${aravis_LIVE_COMMIT:-master}"
- inherit git-2 autotools
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/AravisProject/aravis.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Library for video acquisition using Genicam cameras"
@@ -19,33 +16,35 @@ HOMEPAGE="https://live.gnome.org/Aravis"
LICENSE="LGPL-2.1"
SLOT="0"
+IUSE="X gstreamer caps"
-IUSE="X gstreamer"
+GST_DEPEND="media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0"
-GST_DEPEND="media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10"
-
-RDEPEND=">=dev-libs/glib-2.22
+RDEPEND=">=dev-libs/glib-2.26
dev-libs/libxml2
X? (
- >=x11-libs/gtk+-2.12:2
+ >=x11-libs/gtk+-3.12:3
${GST_DEPEND}
- media-libs/gst-plugins-base:0.10
- media-plugins/gst-plugins-xvideo:0.10
+ media-libs/gst-plugins-base:1.0
+ x11-libs/libnotify
+ )
+ caps? (
+ sys-libs/libcap-ng
+ sys-process/audit
)
gstreamer? ( ${GST_DEPEND} )"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-libs/gobject-introspection"
-if [[ -z ${EGIT_COMMIT} ]]; then
- SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.xz"
-else
+if [[ ${PV} != *9999 ]]; then
DEPEND+=" dev-util/gtk-doc dev-util/intltool"
fi
src_prepare() {
- if [[ -n ${EGIT_COMMIT} ]]; then
+ default
+ if [[ ${PV} = *9999 ]]; then
intltoolize || die
gtkdocize || die
eautoreconf
@@ -58,6 +57,7 @@ src_configure() {
--disable-static \
$(use_enable X viewer) \
$(use_enable gstreamer gst-plugin) \
+ $(use_enable caps packet-socket) \
--enable-introspection
}