summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-12 20:03:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-13 02:17:40 +0200
commitd8664d024841c43663921ca8eff0d17b51bb6b3f (patch)
treea245a567d36b867ed74a1d62842d7909354c6c7a /media-video
parentmedia-video/vlc: Drop USE wma-fixed, disable in 3.0 stable branch (diff)
downloadgentoo-d8664d024841c43663921ca8eff0d17b51bb6b3f.tar.gz
gentoo-d8664d024841c43663921ca8eff0d17b51bb6b3f.tar.bz2
gentoo-d8664d024841c43663921ca8eff0d17b51bb6b3f.zip
media-video/vlc: Add USE libplacebo
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/metadata.xml1
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild10
-rw-r--r--media-video/vlc/vlc-9999.ebuild10
3 files changed, 11 insertions, 10 deletions
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
index 2c87fbf15408..f9ee39a780e3 100644
--- a/media-video/vlc/metadata.xml
+++ b/media-video/vlc/metadata.xml
@@ -25,6 +25,7 @@
<flag name="gstreamer">Enable GStreamer based decoding support (currently supports only video decoding)</flag>
<flag name="kate">Adds support for Ogg Kate subtitles via libkate</flag>
<flag name="kms">Enable kernel mode setting video output plugin via <pkg>x11-libs/libdrm</pkg></flag>
+ <flag name="libplacebo">Enable support for GPU accelerated video rendering with <pkg>media-libs/libplacebo</pkg></flag>
<flag name="libtar">Uses libtar instead of the built-in tar reader for reading custom skins</flag>
<flag name="libtiger">Enable Ogg Kate subtitles rendering using libtiger</flag>
<flag name="linsys">Enable support for Linux Linear Systems Ltd. SDI and HD-SDI input cards</flag>
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index fdde9d6a3eaf..e5550b36b1a2 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -32,10 +32,10 @@ SLOT="0/5-9" # vlc - vlccore
IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromecast
dav1d dbus dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac
fluidsynth fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate
- libass libav libcaca libnotify +libsamplerate libtar libtiger linsys lirc live lua
- macosx-notifications macosx-qtkit mad matroska modplug mp3 mpeg mtp musepack ncurses
- neon nfs ogg omxil opencv optimisememory opus png postproc projectm pulseaudio +qt5
- rdp run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl
+ libass libav libcaca libnotify libplacebo +libsamplerate libtar libtiger linsys lirc
+ live lua macosx-notifications macosx-qtkit mad matroska modplug mp3 mpeg mtp musepack
+ ncurses neon nfs ogg omxil opencv optimisememory opus png postproc projectm pulseaudio
+ +qt5 rdp run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl
svg taglib theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vorbis vpx
wayland +X x264 x265 xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
"
@@ -329,6 +329,7 @@ src_configure() {
$(use_enable libass)
$(use_enable libcaca caca)
$(use_enable libnotify notify)
+ $(use_enable libplacebo)
$(use_enable libsamplerate samplerate)
$(use_enable libtar)
$(use_enable libtiger tiger)
@@ -405,7 +406,6 @@ src_configure() {
--disable-goom
--disable-kai
--disable-kva
- --disable-libplacebo
--disable-maintainer-mode
--disable-merge-ffmpeg
--disable-mfx
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 9354de3beaf1..b37552b3a988 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -32,10 +32,10 @@ SLOT="0/12-9" # vlc - vlccore
IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromecast
dav1d dbus dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac
fluidsynth fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate kms
- libass libav libcaca libnotify +libsamplerate libtar libtiger linsys lirc live lua
- macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
- neon nfs ogg omxil opencv optimisememory opus png postproc projectm pulseaudio +qt5
- rdp run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl
+ libass libav libcaca libnotify libplacebo +libsamplerate libtar libtiger linsys lirc
+ live lua macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
+ neon nfs ogg omxil opencv optimisememory opus png postproc projectm pulseaudio
+ +qt5 rdp run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl
svg taglib theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vorbis vpx
wayland +X x264 x265 xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
"
@@ -331,6 +331,7 @@ src_configure() {
$(use_enable libass)
$(use_enable libcaca caca)
$(use_enable libnotify notify)
+ $(use_enable libplacebo)
$(use_enable libsamplerate samplerate)
$(use_enable libtar)
$(use_enable libtiger tiger)
@@ -404,7 +405,6 @@ src_configure() {
--disable-goom
--disable-kai
--disable-kva
- --disable-libplacebo
--disable-maintainer-mode
--disable-merge-ffmpeg
--disable-mfx