summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-16 10:03:05 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-16 10:03:05 +0200
commitdae8d14c08cd92a30d2231d54cffd154de78f38d (patch)
tree3eaea5b57ee5945fa7151b66bce2675980fb60eb /media-video
parentx11-libs/gtk+extra: treeclean (diff)
downloadgentoo-dae8d14c08cd92a30d2231d54cffd154de78f38d.tar.gz
gentoo-dae8d14c08cd92a30d2231d54cffd154de78f38d.tar.bz2
gentoo-dae8d14c08cd92a30d2231d54cffd154de78f38d.zip
media-video/kino: treeclean
Closes: https://bugs.gentoo.org/740528 Closes: https://bugs.gentoo.org/778338 Closes: https://bugs.gentoo.org/834406 Closes: https://bugs.gentoo.org/438248 Closes: https://bugs.gentoo.org/372053 Closes: https://bugs.gentoo.org/832380 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/kino/Manifest1
-rw-r--r--media-video/kino/files/kino-1.3.4-desktop.patch14
-rw-r--r--media-video/kino/files/kino-1.3.4-ffmpeg3.patch157
-rw-r--r--media-video/kino/files/kino-1.3.4-ffmpeg4.patch13
-rw-r--r--media-video/kino/files/kino-1.3.4-libav-0.7.patch60
-rw-r--r--media-video/kino/files/kino-1.3.4-libav-0.8.patch57
-rw-r--r--media-video/kino/files/kino-1.3.4-libavcodec-pkg-config.patch11
-rw-r--r--media-video/kino/files/kino-1.3.4-v4l1.patch22
-rw-r--r--media-video/kino/kino-1.3.4-r2.ebuild105
-rw-r--r--media-video/kino/metadata.xml14
10 files changed, 0 insertions, 454 deletions
diff --git a/media-video/kino/Manifest b/media-video/kino/Manifest
deleted file mode 100644
index 1fc83d5dce0a..000000000000
--- a/media-video/kino/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST kino-1.3.4.tar.gz 11090771 BLAKE2B 58d61257c09638d12cc4ec1e40fa5f51c6812039825f915b0b8c32817c791c7ce89b69145ffffed8fb65ea21b57d50628bab2654df731b79c39d120ea4335bb9 SHA512 065695e6115f3f994ed89ebf52e64c4b8da100f7a973a8c686fd7e7377104b838968800c6a8e31913fd5e2be568076c60d588b840e51da3d082841546a53fc32
diff --git a/media-video/kino/files/kino-1.3.4-desktop.patch b/media-video/kino/files/kino-1.3.4-desktop.patch
deleted file mode 100644
index 03267e35b48f..000000000000
--- a/media-video/kino/files/kino-1.3.4-desktop.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- kino-1.3.4/Kino.desktop_orig 2021-04-10 11:55:07.696950138 +0200
-+++ kino-1.3.4/Kino.desktop 2021-04-10 11:55:19.621863615 +0200
-@@ -41,9 +41,9 @@
- Encoding=UTF-8
- TryExec=kino
- Exec=kino %F
--Icon=kino.png
-+Icon=kino
- Terminal=false
- StartupNotify=true
- Type=Application
--Categories=Application;AudioVideo;AudioVideoEditing;
-+Categories=AudioVideo;AudioVideoEditing;
- MimeType=video/dv;application/smil
diff --git a/media-video/kino/files/kino-1.3.4-ffmpeg3.patch b/media-video/kino/files/kino-1.3.4-ffmpeg3.patch
deleted file mode 100644
index 57849d74e5c9..000000000000
--- a/media-video/kino/files/kino-1.3.4-ffmpeg3.patch
+++ /dev/null
@@ -1,157 +0,0 @@
---- ./src.orig/frame.cc 2016-12-18 12:25:48.480275083 -0600
-+++ ./src/frame.cc 2016-12-18 12:54:17.800740672 -0600
-@@ -103,7 +103,7 @@
- av_register_all();
- libavcodec = avcodec_alloc_context3(NULL);
- avcodec_open2( libavcodec,
-- avcodec_find_decoder( CODEC_ID_DVVIDEO ), NULL );
-+ avcodec_find_decoder( AV_CODEC_ID_DVVIDEO ), NULL );
- pthread_mutex_unlock( &avcodec_mutex );
- data = ( unsigned char* ) av_mallocz( 144000 );
- #if defined(HAVE_SWSCALE)
-@@ -1060,7 +1060,7 @@
- int Frame::ExtractRGB( void * rgb )
- {
- #if defined(HAVE_LIBAVCODEC)
-- AVFrame *frame = avcodec_alloc_frame();
-+ AVFrame *frame = av_frame_alloc();
- AVPicture dest;
- int got_picture;
-
-@@ -1072,17 +1072,17 @@
- avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
- if ( got_picture )
- {
-- avpicture_fill( &dest, static_cast<uint8_t*>( rgb ), PIX_FMT_RGB24, GetWidth(), GetHeight() );
-+ avpicture_fill( &dest, static_cast<uint8_t*>( rgb ), AV_PIX_FMT_RGB24, GetWidth(), GetHeight() );
- #if defined(HAVE_SWSCALE)
- if ( !imgConvertRgbCtx )
- imgConvertRgbCtx = sws_getContext( libavcodec->width, libavcodec->height, libavcodec->pix_fmt,
-- GetWidth(), GetHeight(), PIX_FMT_RGB24, SWS_FAST_BILINEAR, NULL, NULL, NULL );
-+ GetWidth(), GetHeight(), AV_PIX_FMT_RGB24, SWS_FAST_BILINEAR, NULL, NULL, NULL );
- sws_scale( imgConvertRgbCtx, frame->data, frame->linesize, 0, libavcodec->height, dest.data, dest.linesize );
- #else
-- img_convert( &dest, PIX_FMT_RGB24, reinterpret_cast<AVPicture*>( frame ), libavcodec->pix_fmt, GetWidth(), GetHeight() );
-+ img_convert( &dest, AV_PIX_FMT_RGB24, reinterpret_cast<AVPicture*>( frame ), libavcodec->pix_fmt, GetWidth(), GetHeight() );
- #endif
- }
-- av_free( frame );
-+ av_frame_free( &frame );
- #else
- unsigned char *pixels[ 3 ];
- int pitches[ 3 ];
-@@ -1125,7 +1125,7 @@
- int Frame::ExtractYUV( void *yuv )
- {
- #if defined(HAVE_LIBAVCODEC)
-- AVFrame *frame = avcodec_alloc_frame();;
-+ AVFrame *frame = av_frame_alloc();;
- AVPicture output;
- int got_picture;
-
-@@ -1137,14 +1137,14 @@
- avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
- if ( got_picture )
- {
-- avpicture_fill( &output, static_cast<uint8_t*>( yuv ), PIX_FMT_YUV422, GetWidth(), GetHeight() );
-+ avpicture_fill( &output, static_cast<uint8_t*>( yuv ), AV_PIX_FMT_YUYV422, GetWidth(), GetHeight() );
- #if defined(HAVE_SWSCALE)
- if ( !imgConvertYuvCtx )
- imgConvertYuvCtx = sws_getContext( libavcodec->width, libavcodec->height, libavcodec->pix_fmt,
-- GetWidth(), GetHeight(), PIX_FMT_YUV422, SWS_FAST_BILINEAR, NULL, NULL, NULL );
-+ GetWidth(), GetHeight(), AV_PIX_FMT_YUYV422, SWS_FAST_BILINEAR, NULL, NULL, NULL );
- sws_scale( imgConvertYuvCtx, frame->data, frame->linesize, 0, libavcodec->height, output.data, output.linesize );
- #else
-- img_convert( &output, PIX_FMT_YUV422, (AVPicture *)frame, libavcodec->pix_fmt, GetWidth(), GetHeight() );
-+ img_convert( &output, AV_PIX_FMT_YUYV422, (AVPicture *)frame, libavcodec->pix_fmt, GetWidth(), GetHeight() );
- #endif
- }
- av_free( frame );
-@@ -1164,7 +1164,7 @@
- int Frame::ExtractYUV420( uint8_t *yuv, uint8_t *output[ 3 ] )
- {
- #if defined(HAVE_LIBAVCODEC)
-- AVFrame *frame = avcodec_alloc_frame();
-+ AVFrame *frame = av_frame_alloc();
- int got_picture;
-
- AVPacket pkt;
-@@ -1176,7 +1176,7 @@
-
- int width = GetWidth(), height = GetHeight();
-
-- if ( libavcodec->pix_fmt == PIX_FMT_YUV420P ) // PAL
-+ if ( libavcodec->pix_fmt == AV_PIX_FMT_YUV420P ) // PAL
- {
- int h2 = height / 2;
- int w2 = width / 2;
-@@ -1204,7 +1204,7 @@
- }
- }
- }
-- else // libavcodec.pix_fmt == PIX_FMT_YUV411P // NTSC
-+ else // libavcodec.pix_fmt == AV_PIX_FMT_YUV411P // NTSC
- {
- int w4 = width / 4;
-
-@@ -1341,7 +1341,7 @@
- avformatEncoder->oformat = av_guess_format( "dv", NULL, NULL );
- AVStream* vst = avformat_new_stream( avformatEncoder, NULL );
- vst->codec->codec_type = AVMEDIA_TYPE_VIDEO;
-- vst->codec->codec_id = CODEC_ID_DVVIDEO;
-+ vst->codec->codec_id = AV_CODEC_ID_DVVIDEO;
- vst->codec->bit_rate = 25000000;
- vst->start_time = 0;
- AVCodecContext *avcodecEncoder = vst->codec;
-@@ -1366,14 +1366,14 @@
- #endif
- avcodecEncoder->thread_count = 2;
- avcodecEncoder->time_base= isPAL ? ( AVRational ){ 1, 25 } : ( AVRational ){ 1001, 30000 };
-- avcodecEncoder->pix_fmt = isPAL ? PIX_FMT_YUV420P : PIX_FMT_YUV411P;
-+ avcodecEncoder->pix_fmt = isPAL ? AV_PIX_FMT_YUV420P : AV_PIX_FMT_YUV411P;
- avcodecEncoder->flags |= CODEC_FLAG_INTERLACED_DCT;
-- avcodec_open2( avcodecEncoder, avcodec_find_encoder( CODEC_ID_DVVIDEO ), NULL );
-+ avcodec_open2( avcodecEncoder, avcodec_find_encoder( AV_CODEC_ID_DVVIDEO ), NULL );
- av_new_packet( &avpacketEncoder, 144000 );
- tempImage = ( uint8_t* ) av_malloc(
- avpicture_get_size( avcodecEncoder->pix_fmt, avcodecEncoder->width, avcodecEncoder->height ) );
- #if defined(HAVE_SWSCALE)
-- imgConvertEncoderCtx = sws_getContext( avcodecEncoder->width, avcodecEncoder->height, PIX_FMT_RGB24,
-+ imgConvertEncoderCtx = sws_getContext( avcodecEncoder->width, avcodecEncoder->height, AV_PIX_FMT_RGB24,
- avcodecEncoder->width, avcodecEncoder->height, avcodecEncoder->pix_fmt, SWS_FAST_BILINEAR, NULL, NULL, NULL);
- #endif
- }
-@@ -1452,8 +1452,8 @@
- if ( CreateEncoder( IsPAL(), IsWide() ) )
- {
- #if defined(HAVE_LIBAVCODEC)
-- AVFrame *input = avcodec_alloc_frame();
-- AVFrame *output = avcodec_alloc_frame();
-+ AVFrame *input = av_frame_alloc();
-+ AVFrame *output = av_frame_alloc();
-
- if ( input && output )
- {
-@@ -1464,16 +1464,19 @@
-
- // Convert color space
- avpicture_fill( ( AVPicture* )output, tempImage, avcodecEncoder->pix_fmt, width, height );
-- avpicture_fill( ( AVPicture* )input, rgb, PIX_FMT_RGB24, width, height );
-+ avpicture_fill( ( AVPicture* )input, rgb, AV_PIX_FMT_RGB24, width, height );
- #if defined(HAVE_SWSCALE)
- sws_scale( imgConvertEncoderCtx, input->data, input->linesize, 0, height,
- output->data, output->linesize);
- #else
-- img_convert( ( AVPicture* )output, avcodecEncoder->pix_fmt, ( AVPicture* )input, PIX_FMT_RGB24, width, height );
-+ img_convert( ( AVPicture* )output, avcodecEncoder->pix_fmt, ( AVPicture* )input, AV_PIX_FMT_RGB24, width, height );
- #endif
-
- // Encode
-- bytesInFrame = avcodec_encode_video( avcodecEncoder, avpacketEncoder.data, size, output );
-+
-+ // bytesInFrame = avcodec_encode_video( avcodecEncoder, avpacketEncoder.data, size, output );
-+ int got_packet;
-+ bytesInFrame = avcodec_encode_video2( avcodecEncoder, &avpacketEncoder, output, &got_packet );
- avformatEncoder->pb = avio_alloc_context(data, bytesInFrame, 0, NULL, NULL, NULL, NULL);
- avpacketEncoder.size = bytesInFrame;
- if ( !isEncoderHeaderWritten )
diff --git a/media-video/kino/files/kino-1.3.4-ffmpeg4.patch b/media-video/kino/files/kino-1.3.4-ffmpeg4.patch
deleted file mode 100644
index b0f359f06ba3..000000000000
--- a/media-video/kino/files/kino-1.3.4-ffmpeg4.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/old/frame.cc b/src/frame.cc
-index c88508f..1e2573a 100644
---- a/old/frame.cc
-+++ b/src/frame.cc
-@@ -1367,7 +1367,7 @@ bool Frame::CreateEncoder( bool isPAL, bool isWide )
- avcodecEncoder->thread_count = 2;
- avcodecEncoder->time_base= isPAL ? ( AVRational ){ 1, 25 } : ( AVRational ){ 1001, 30000 };
- avcodecEncoder->pix_fmt = isPAL ? AV_PIX_FMT_YUV420P : AV_PIX_FMT_YUV411P;
-- avcodecEncoder->flags |= CODEC_FLAG_INTERLACED_DCT;
-+ avcodecEncoder->flags |= AV_CODEC_FLAG_INTERLACED_DCT;
- avcodec_open2( avcodecEncoder, avcodec_find_encoder( AV_CODEC_ID_DVVIDEO ), NULL );
- av_new_packet( &avpacketEncoder, 144000 );
- tempImage = ( uint8_t* ) av_malloc(
diff --git a/media-video/kino/files/kino-1.3.4-libav-0.7.patch b/media-video/kino/files/kino-1.3.4-libav-0.7.patch
deleted file mode 100644
index 65c5bc38276d..000000000000
--- a/media-video/kino/files/kino-1.3.4-libav-0.7.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- kino-1.3.4.orig/src/frame.cc 2011-07-17 14:54:59.089481638 +0200
-+++ kino-1.3.4/src/frame.cc 2011-07-17 15:09:23.199481714 +0200
-@@ -1063,7 +1063,12 @@
- AVPicture dest;
- int got_picture;
-
-- avcodec_decode_video( libavcodec, frame, &got_picture, data, GetFrameSize() );
-+ AVPacket pkt;
-+ av_init_packet(&pkt);
-+ pkt.data = data;
-+ pkt.size = GetFrameSize();
-+
-+ avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
- if ( got_picture )
- {
- avpicture_fill( &dest, static_cast<uint8_t*>( rgb ), PIX_FMT_RGB24, GetWidth(), GetHeight() );
-@@ -1123,7 +1128,12 @@
- AVPicture output;
- int got_picture;
-
-- avcodec_decode_video( libavcodec, frame, &got_picture, data, GetFrameSize() );
-+ AVPacket pkt;
-+ av_init_packet(&pkt);
-+ pkt.data = data;
-+ pkt.size = GetFrameSize();
-+
-+ avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
- if ( got_picture )
- {
- avpicture_fill( &output, static_cast<uint8_t*>( yuv ), PIX_FMT_YUV422, GetWidth(), GetHeight() );
-@@ -1156,7 +1166,12 @@
- AVFrame *frame = avcodec_alloc_frame();
- int got_picture;
-
-- avcodec_decode_video( libavcodec, frame, &got_picture, data, GetFrameSize() );
-+ AVPacket pkt;
-+ av_init_packet(&pkt);
-+ pkt.data = data;
-+ pkt.size = GetFrameSize();
-+
-+ avcodec_decode_video2( libavcodec, frame, &got_picture, &pkt );
-
- int width = GetWidth(), height = GetHeight();
-
-@@ -1319,12 +1334,12 @@
- #if defined(HAVE_LIBAVCODEC)
- if ( avformatEncoder == NULL )
- {
-- avformatEncoder = av_alloc_format_context();
-+ avformatEncoder = avformat_alloc_context();
- if ( avformatEncoder )
- {
-- avformatEncoder->oformat = guess_format( "dv", NULL, NULL );
-+ avformatEncoder->oformat = av_guess_format( "dv", NULL, NULL );
- AVStream* vst = av_new_stream( avformatEncoder, 0 );
-- vst->codec->codec_type = CODEC_TYPE_VIDEO;
-+ vst->codec->codec_type = AVMEDIA_TYPE_VIDEO;
- vst->codec->codec_id = CODEC_ID_DVVIDEO;
- vst->codec->bit_rate = 25000000;
- vst->start_time = 0;
diff --git a/media-video/kino/files/kino-1.3.4-libav-0.8.patch b/media-video/kino/files/kino-1.3.4-libav-0.8.patch
deleted file mode 100644
index f98cbda0bc49..000000000000
--- a/media-video/kino/files/kino-1.3.4-libav-0.8.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- kino-1.3.4.orig/src/frame.cc 2012-05-14 19:55:42.153772418 -0700
-+++ kino-1.3.4/src/frame.cc 2012-05-14 20:28:34.448838653 -0700
-@@ -101,8 +101,9 @@
- #if defined(HAVE_LIBAVCODEC)
- pthread_mutex_lock( &avcodec_mutex );
- av_register_all();
-- libavcodec = avcodec_alloc_context();
-- avcodec_open( libavcodec, avcodec_find_decoder( CODEC_ID_DVVIDEO ) );
-+ libavcodec = avcodec_alloc_context3(NULL);
-+ avcodec_open2( libavcodec,
-+ avcodec_find_decoder( CODEC_ID_DVVIDEO ), NULL );
- pthread_mutex_unlock( &avcodec_mutex );
- data = ( unsigned char* ) av_mallocz( 144000 );
- #if defined(HAVE_SWSCALE)
-@@ -1338,7 +1339,7 @@
- if ( avformatEncoder )
- {
- avformatEncoder->oformat = av_guess_format( "dv", NULL, NULL );
-- AVStream* vst = av_new_stream( avformatEncoder, 0 );
-+ AVStream* vst = avformat_new_stream( avformatEncoder, NULL );
- vst->codec->codec_type = AVMEDIA_TYPE_VIDEO;
- vst->codec->codec_id = CODEC_ID_DVVIDEO;
- vst->codec->bit_rate = 25000000;
-@@ -1364,12 +1365,10 @@
- vst->sample_aspect_ratio = avcodecEncoder->sample_aspect_ratio;
- #endif
- avcodecEncoder->thread_count = 2;
-- avcodec_thread_init( avcodecEncoder, avcodecEncoder->thread_count );
- avcodecEncoder->time_base= isPAL ? ( AVRational ){ 1, 25 } : ( AVRational ){ 1001, 30000 };
- avcodecEncoder->pix_fmt = isPAL ? PIX_FMT_YUV420P : PIX_FMT_YUV411P;
- avcodecEncoder->flags |= CODEC_FLAG_INTERLACED_DCT;
-- av_set_parameters( avformatEncoder, NULL );
-- avcodec_open( avcodecEncoder, avcodec_find_encoder( CODEC_ID_DVVIDEO ) );
-+ avcodec_open2( avcodecEncoder, avcodec_find_encoder( CODEC_ID_DVVIDEO ), NULL );
- av_new_packet( &avpacketEncoder, 144000 );
- tempImage = ( uint8_t* ) av_malloc(
- avpicture_get_size( avcodecEncoder->pix_fmt, avcodecEncoder->width, avcodecEncoder->height ) );
-@@ -1475,16 +1474,16 @@
-
- // Encode
- bytesInFrame = avcodec_encode_video( avcodecEncoder, avpacketEncoder.data, size, output );
-- url_open_buf( &avformatEncoder->pb, data, bytesInFrame, URL_WRONLY );
-+ avformatEncoder->pb = avio_alloc_context(data, bytesInFrame, 0, NULL, NULL, NULL, NULL);
- avpacketEncoder.size = bytesInFrame;
- if ( !isEncoderHeaderWritten )
- {
-- av_write_header( avformatEncoder );
-+ avformat_write_header( avformatEncoder, NULL );
- isEncoderHeaderWritten = true;
- }
- av_write_frame( avformatEncoder, &avpacketEncoder );
- #if LIBAVFORMAT_VERSION_INT >= ((52<<16)+(0<<8)+0)
-- url_close_buf( avformatEncoder->pb );
-+ avio_close( avformatEncoder->pb );
- #else
- url_close_buf( &avformatEncoder->pb );
- #endif
diff --git a/media-video/kino/files/kino-1.3.4-libavcodec-pkg-config.patch b/media-video/kino/files/kino-1.3.4-libavcodec-pkg-config.patch
deleted file mode 100644
index c5cd12106f5c..000000000000
--- a/media-video/kino/files/kino-1.3.4-libavcodec-pkg-config.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.in 2009-09-08 02:35:23.000000000 -0400
-+++ b/configure.in 2014-01-27 14:53:01.366063037 -0500
-@@ -221,7 +221,7 @@
- if (test "x$avcodec_include" != x) || (test "x$avcodec_lib" != x) ; then
- local_legacy_ffmpeg_test
- else
-- PKG_CHECK_MODULES(AVCODEC, libavformat,
-+ PKG_CHECK_MODULES(AVCODEC, [libavcodec libavformat libavutil],
- [
- AC_DEFINE(HAVE_LIBAVCODEC, 1, [Enable FFMPEG libavcodec])
- AC_SUBST(AVCODEC_LIBS)
diff --git a/media-video/kino/files/kino-1.3.4-v4l1.patch b/media-video/kino/files/kino-1.3.4-v4l1.patch
deleted file mode 100644
index c6757743cd7e..000000000000
--- a/media-video/kino/files/kino-1.3.4-v4l1.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- kino-1.3.3.orig/ffmpeg/libavdevice/v4l.c 2011-05-17 02:20:37.161004916 +0400
-+++ kino-1.3.3.orig/ffmpeg/libavdevice/v4l.c 2011-05-17 02:21:57.302377529 +0400
-@@ -26,7 +26,7 @@
- #include <sys/mman.h>
- #include <sys/time.h>
- #define _LINUX_TIME_H 1
--#include <linux/videodev.h>
-+#include <libv4l1-videodev.h>
- #include <time.h>
-
- typedef struct {
---- kino-1.3.3.orig/src/v4l.h 2011-05-17 02:20:38.896969666 +0400
-+++ kino-1.3.3.orig/src/v4l.h 2011-05-17 02:21:39.922730395 +0400
-@@ -40,7 +40,7 @@
-
- #define _DEVICE_H_
- #define _LINUX_TIME_H
--#include <linux/videodev.h>
-+#include <libv4l1-videodev.h>
-
- #include "displayer.h"
-
diff --git a/media-video/kino/kino-1.3.4-r2.ebuild b/media-video/kino/kino-1.3.4-r2.ebuild
deleted file mode 100644
index c34910775617..000000000000
--- a/media-video/kino/kino-1.3.4-r2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools udev xdg
-
-DESCRIPTION="Non-linear DV editor for GNU/Linux"
-HOMEPAGE="http://www.kinodv.org/"
-SRC_URI="mirror://sourceforge/kino/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="alsa dvdr gpac lame quicktime sox vorbis"
-
-# Optional dependency on cinelerra-cvs (as a replacement for libquicktime)
-# dropped because kino may run with it but won't build anymore.
-DEPEND="
- >=x11-libs/gtk+-2.6.0:2
- >=gnome-base/libglade-2.5.0
- >=dev-libs/glib-2:2
- x11-libs/libXv
- dev-libs/libxml2:2
- media-libs/audiofile
- >=sys-libs/libraw1394-1.0.0
- >=sys-libs/libavc1394-0.4.1
- >=media-libs/libdv-0.103
- media-libs/libsamplerate
- media-libs/libiec61883
- media-libs/libv4l:0=
- alsa? ( >=media-libs/alsa-lib-1.0.9 )
- >=media-video/ffmpeg-3:0=
- quicktime? ( >=media-libs/libquicktime-0.9.5 )
-"
-RDEPEND="${DEPEND}
- media-video/mjpegtools
- media-sound/rawrec
- dvdr? ( media-video/dvdauthor
- app-cdr/dvd+rw-tools )
- gpac? ( media-video/gpac )
- lame? ( media-sound/lame )
- sox? ( media-sound/sox )
- vorbis? ( media-sound/vorbis-tools )
-"
-BDEPEND="
- dev-util/glib-utils
- dev-util/intltool
-"
-
-src_prepare() {
- default
-
- # Deactivating automagic alsa configuration, bug #134725
- if ! use alsa ; then
- sed -i -e "s:HAVE_ALSA 1:HAVE_ALSA 0:" configure || die
- fi
-
- # Fix bug #169590
- sed -i \
- -e '/\$(LIBQUICKTIME_LIBS) \\/d' \
- -e '/^[[:space:]]*\$(SRC_LIBS)/ a\
- \$(LIBQUICKTIME_LIBS) \\' \
- src/Makefile.in || die
-
- # Fix test failure discovered in bug #193947
- sed -i -e '$a\
-\
-ffmpeg/libavcodec/ps2/idct_mmi.c\
-ffmpeg/libavcodec/sparc/dsputil_vis.c\
-ffmpeg/libavcodec/sparc/vis.h\
-ffmpeg/libavutil/bswap.h\
-ffmpeg/libswscale/yuv2rgb_template.c\
-src/export.h\
-src/message.cc\
-src/page_bttv.cc' po/POTFILES.in || die
-
- sed -i -e 's:^#include <quicktime.h>:#include <lqt/quicktime.h>:' src/filehandler.h || die
- eapply "${FILESDIR}/${P}-v4l1.patch"
- eapply "${FILESDIR}/${P}-libav-0.7.patch"
- eapply "${FILESDIR}/${P}-libav-0.8.patch"
- eapply "${FILESDIR}/${P}-libavcodec-pkg-config.patch"
- eapply "${FILESDIR}/${P}-ffmpeg3.patch"
- eapply "${FILESDIR}/${P}-ffmpeg4.patch"
- eapply "${FILESDIR}/${P}-desktop.patch"
-
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-local-ffmpeg \
- $(use_enable quicktime) \
- $(use_with sparc dv1394) \
- --with-udev-rules-dir="$(get_udevdir)"/rules.d \
- CPPFLAGS="-I${ESYSROOT}usr/include/libavcodec -I${ESYSROOT}usr/include/libavformat -I${ESYSROOT}usr/include/libswscale"
-}
-
-src_install() {
- default
- mv "${ED}/$(get_udevdir)"/rules.d/{,99-}kino.rules || die
- fowners root:root -R /usr/share/kino/help #177378
- find "${ED}" -name '*.la' -delete || die #385361
-}
diff --git a/media-video/kino/metadata.xml b/media-video/kino/metadata.xml
deleted file mode 100644
index 85d3482c21f9..000000000000
--- a/media-video/kino/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- <name>Gentoo Video project</name>
- </maintainer>
- <use>
- <flag name="gpac">Enable GPAC support when exporting to 3GPP format</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">kino</remote-id>
- </upstream>
-</pkgmetadata>