summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-22 12:50:40 -0400
committerRick Farina <zerochaos@gentoo.org>2020-05-22 13:22:11 -0400
commite21afa26df49217beb52db57ff86962908942a73 (patch)
treea8a7481566f1daec1c145bf12f6d1e5257342303 /media-video
parentdev-python/pyside2: adding ~x86 (diff)
downloadgentoo-e21afa26df49217beb52db57ff86962908942a73.tar.gz
gentoo-e21afa26df49217beb52db57ff86962908942a73.tar.bz2
gentoo-e21afa26df49217beb52db57ff86962908942a73.zip
media-video/streamdeck-ui: initial ebuild
I'm sure it's wrong Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/streamdeck-ui/Manifest1
-rw-r--r--media-video/streamdeck-ui/metadata.xml11
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-0.0_p20200102.ebuild32
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-9999.ebuild32
4 files changed, 76 insertions, 0 deletions
diff --git a/media-video/streamdeck-ui/Manifest b/media-video/streamdeck-ui/Manifest
new file mode 100644
index 000000000000..979a7f4293ca
--- /dev/null
+++ b/media-video/streamdeck-ui/Manifest
@@ -0,0 +1 @@
+DIST streamdeck-ui-0.0_p20200102.tar.gz 2512712 BLAKE2B f5abad75c77410127f51de0e4ad7ce112f59ff3652afa32f9aefe44cbb69e16a09991322091ba39d259d9bb1e35dd0833a1b58457d095f21eec258b8967ded9e SHA512 345d0a2cfadb23e20925749e06e99976d533968fffe8b6db77dfeffbb1716c4042f84e6c1c616e0986e7da3592be2046f2a6e0de1942da34b6712de70cdce649
diff --git a/media-video/streamdeck-ui/metadata.xml b/media-video/streamdeck-ui/metadata.xml
new file mode 100644
index 000000000000..64951f439f8a
--- /dev/null
+++ b/media-video/streamdeck-ui/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sidhayn@gmail.com</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">timothycrosley/streamdeck-ui</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/streamdeck-ui/streamdeck-ui-0.0_p20200102.ebuild b/media-video/streamdeck-ui/streamdeck-ui-0.0_p20200102.ebuild
new file mode 100644
index 000000000000..310b80a78328
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-0.0_p20200102.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ COMMIT="9b6678d2d3027963ddac147ee3aeda322ec77f29"
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ dev-libs/hidapi"
+RDEPEND="${DEPEND}"
diff --git a/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild b/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
new file mode 100644
index 000000000000..310b80a78328
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ COMMIT="9b6678d2d3027963ddac147ee3aeda322ec77f29"
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ dev-libs/hidapi"
+RDEPEND="${DEPEND}"