summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-01 17:09:31 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-01 18:17:40 +0200
commitebd97f5185301f60902cef42029db41cfce53580 (patch)
treeaf8a0716734feb7c4886e9a2d0157a0b5b8581ca /media-video
parentgnome-base/gnome-shell: bump to 3.34.4 (diff)
downloadgentoo-ebd97f5185301f60902cef42029db41cfce53580.tar.gz
gentoo-ebd97f5185301f60902cef42029db41cfce53580.tar.bz2
gentoo-ebd97f5185301f60902cef42029db41cfce53580.zip
media-video/cheese-3.34: various packaging fixes
* Drop IUSE=X, it is NOT optional * Replace wrong intltool dep with gettext * Fix USE=gtk-doc deps * Fix lack of gnome2_schemas_update calls * Use xdg.eclass instead of xdg-utils.eclass (and get missing env reset from that added back) * Re-enable tests, they appear to work fine Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cheese/cheese-3.34.0-r1.ebuild (renamed from media-video/cheese/cheese-3.34.0.ebuild)63
1 files changed, 28 insertions, 35 deletions
diff --git a/media-video/cheese/cheese-3.34.0.ebuild b/media-video/cheese/cheese-3.34.0-r1.ebuild
index 5260911df0d1..17d4540d9887 100644
--- a/media-video/cheese/cheese-3.34.0.ebuild
+++ b/media-video/cheese/cheese-3.34.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit gnome.org meson vala virtualx xdg-utils
+inherit gnome.org meson vala virtualx xdg
DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
@@ -11,41 +11,30 @@ HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
LICENSE="GPL-2+"
SLOT="0/8" # subslot = libcheese soname version
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="gtk-doc +introspection test X"
-RESTRICT="test" # Tests fail
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( X )"
-COMMON_DEPEND="
- >=dev-libs/glib-2.39.90:2
- >=x11-libs/gtk+-3.13.4:3[introspection?]
- >=gnome-base/gnome-desktop-2.91.6:3=
- >=media-libs/libcanberra-0.26[gtk3]
+DEPEND="
>=media-libs/clutter-1.13.2:1.0[introspection?]
- >=media-libs/clutter-gtk-0.91.8:1.0
media-libs/clutter-gst:3.0
- media-libs/cogl:1.0=[introspection?]
-
- media-video/gnome-video-effects
+ >=media-libs/clutter-gtk-0.91.8:1.0
x11-libs/gdk-pixbuf:2[jpeg,introspection?]
-
+ >=dev-libs/glib-2.39.90:2
+ >=gnome-base/gnome-desktop-2.91.6:3=
>=media-libs/gstreamer-1.4:1.0[introspection?]
- >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X?]
-
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ >=media-libs/gst-plugins-base-1.4:1.0[ogg,pango,theora,vorbis]
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=x11-libs/gtk+-3.13.4:3
+ >=media-libs/libcanberra-0.26[gtk3]
+ x11-libs/libX11
+ sys-apps/dbus
+ media-video/gnome-video-effects
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
- X? (
- x11-base/xorg-proto
- x11-libs/libX11
- )
-"
+ media-libs/cogl:1.0=[introspection?]
-DEPEND="
- ${COMMON_DEPEND}
- test? ( x11-libs/libXtst )
"
-
-RDEPEND="${COMMON_DEPEND}
- >=media-libs/gst-plugins-bad-1.4:1.0
+RDEPEND="${DEPEND}
>=media-libs/gst-plugins-good-1.4:1.0
>=media-plugins/gst-plugins-jpeg-1.4:1.0
@@ -54,15 +43,18 @@ RDEPEND="${COMMON_DEPEND}
"
BDEPEND="
- $(vala_depend)
+ gtk-doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
app-text/docbook-xml-dtd:4.3
dev-util/itstool
dev-libs/appstream-glib
- >=dev-util/intltool-0.50
- dev-libs/libxslt
dev-libs/libxml2:2
dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( x11-libs/libXtst )
+ $(vala_depend)
"
PATCHES=(
@@ -71,9 +63,8 @@ PATCHES=(
)
src_prepare() {
+ xdg_src_prepare
vala_src_prepare
-
- default
}
src_configure() {
@@ -95,9 +86,11 @@ src_test() {
}
pkg_postinst() {
- xdg_icon_cache_update
+ xdg_pkg_postinst
+ gnome2_schemas_update
}
pkg_postrm() {
- xdg_icon_cache_update
+ xdg_pkg_postrm
+ gnome2_schemas_update
}