summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-26 10:03:04 +0100
committerSam James <sam@gentoo.org>2021-10-26 10:03:04 +0100
commited43ceec5a8e60307c3582dc123acbef6088e725 (patch)
treedb95d77ea955abf26bd82870381e1aafb9f41050 /media-video
parentmedia-video/pipewire: add build fixes for some arches (diff)
downloadgentoo-ed43ceec5a8e60307c3582dc123acbef6088e725.tar.gz
gentoo-ed43ceec5a8e60307c3582dc123acbef6088e725.tar.bz2
gentoo-ed43ceec5a8e60307c3582dc123acbef6088e725.zip
media-video/pipewire: add big endian patch for 0.3.39
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/pipewire/files/pipewire-0.3.39-endian-test-fix.patch31
-rw-r--r--media-video/pipewire/pipewire-0.3.39-r2.ebuild (renamed from media-video/pipewire/pipewire-0.3.39-r1.ebuild)1
2 files changed, 32 insertions, 0 deletions
diff --git a/media-video/pipewire/files/pipewire-0.3.39-endian-test-fix.patch b/media-video/pipewire/files/pipewire-0.3.39-endian-test-fix.patch
new file mode 100644
index 000000000000..a8febb814912
--- /dev/null
+++ b/media-video/pipewire/files/pipewire-0.3.39-endian-test-fix.patch
@@ -0,0 +1,31 @@
+https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/5dfc3494dc4635918e74b9f3d717a39a74b28554.patch
+
+From 5dfc3494dc4635918e74b9f3d717a39a74b28554 Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Mon, 25 Oct 2021 16:15:17 +0200
+Subject: [PATCH] map: use uintptr_t for the next pointer
+
+This aligns the low bits of the next field with the low bits of the
+pointer on big endian cpus.
+
+Fixes #1747
+---
+ src/pipewire/map.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/pipewire/map.h b/src/pipewire/map.h
+index f47dfa6b3..1867fa4d3 100644
+--- a/src/pipewire/map.h
++++ b/src/pipewire/map.h
+@@ -74,7 +74,7 @@ extern "C" {
+ * first item to get re-used on the next insert.
+ */
+ union pw_map_item {
+- uint32_t next; /* next free index */
++ uintptr_t next; /* next free index */
+ void *data; /* data of this item, must be an even address */
+ };
+
+--
+GitLab
+
diff --git a/media-video/pipewire/pipewire-0.3.39-r1.ebuild b/media-video/pipewire/pipewire-0.3.39-r2.ebuild
index 0b9ee48f0903..ffb2156cd8fb 100644
--- a/media-video/pipewire/pipewire-0.3.39-r1.ebuild
+++ b/media-video/pipewire/pipewire-0.3.39-r2.ebuild
@@ -102,6 +102,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
# Upstream
"${FILESDIR}"/${P}-fix-build-some-arches.patch
+ "${FILESDIR}"/${P}-endian-test-fix.patch
)
# limitsdfile related code taken from =sys-auth/realtime-base-0.1