summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/argus-clients
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/argus-clients')
-rw-r--r--net-analyzer/argus-clients/Manifest1
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.8.ebuild73
-rw-r--r--net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch23
-rw-r--r--net-analyzer/argus-clients/files/argus-clients-3.0.7.21-curses-readline.patch21
-rw-r--r--net-analyzer/argus-clients/metadata.xml7
5 files changed, 125 insertions, 0 deletions
diff --git a/net-analyzer/argus-clients/Manifest b/net-analyzer/argus-clients/Manifest
new file mode 100644
index 000000000000..60024d3424d8
--- /dev/null
+++ b/net-analyzer/argus-clients/Manifest
@@ -0,0 +1 @@
+DIST argus-clients-3.0.8.tar.gz 2627515 SHA256 aee8585d50959e00070a382f3121edfaa844a0a51dc0b73edf84c0f4eb8912c9 SHA512 79022b3c3e472ebc526b27c20c25ae97abdb9a363a91ebbe3baf405f2aba9bdd80fbc0250b444d3d7ab4488e3c1325389a4719e92d9aded7598a91c3309369c2 WHIRLPOOL 5147a80ade6beaa44029253807033b1257b0826631deba66cb1176d82919e7e454b5e95df453d15e5a0a6b9b6e09472ab84d21b06ae97e69fca4217028513849
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.8.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.8.ebuild
new file mode 100644
index 000000000000..690bb134abd0
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug ft geoip mysql sasl tcpd"
+
+MY_CDEPEND="
+ net-analyzer/rrdtool[perl]
+ net-libs/libpcap
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+ ft? ( net-analyzer/flow-tools )
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+
+RDEPEND="
+ ${MY_CDEPEND}
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.7.21-curses-readline.patch
+
+ sed -i -e 's| ar | $(AR) |g' common/Makefile.in || die
+ tc-export AR RANLIB
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ econf \
+ $(use_with ft libft) \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with sasl) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ # racurses uses both libncurses and libtinfo, if present
+ emake \
+ CCOPT="${CFLAGS} ${LDFLAGS}" \
+ RANLIB=$(tc-getRANLIB) \
+ CURSESLIB="$( $(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}
diff --git a/net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch b/net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch
new file mode 100644
index 000000000000..a08d974ce893
--- /dev/null
+++ b/net-analyzer/argus-clients/files/argus-clients-3.0.4.1-disable-tcp-wrappers-automagic.patch
@@ -0,0 +1,23 @@
+--- configure.ac.org 2011-01-28 18:26:54.000000000 +0100
++++ configure.ac 2011-04-20 00:09:37.000000000 +0200
+@@ -121,6 +121,12 @@
+ esac
+
+ AC_QOSIENT_THREADS(V_THREADS)
++
++AC_ARG_WITH(wrappers,
++ [ --with-wrappers build with libwrappers suuport],
++ with_wrappers="$withval",
++ with_wrappers="yes")
++if test "x$with_wrappers" != "xno"; then
+ AC_QOSIENT_TCPWRAP(V_WRAPDEP, V_INCLS)
+ if test ! -z "$V_WRAPDEP"; then
+ if test -f $V_WRAPDEP; then
+@@ -144,6 +150,7 @@
+ AC_DEFINE([HAVE_TCP_WRAPPER], [], [Using Tcp wrappers])
+ WRAPLIBS="$V_WRAPDEP"
+ fi
++fi
+
+ CURSESLIB=""
+
diff --git a/net-analyzer/argus-clients/files/argus-clients-3.0.7.21-curses-readline.patch b/net-analyzer/argus-clients/files/argus-clients-3.0.7.21-curses-readline.patch
new file mode 100644
index 000000000000..787ff5ac9118
--- /dev/null
+++ b/net-analyzer/argus-clients/files/argus-clients-3.0.7.21-curses-readline.patch
@@ -0,0 +1,21 @@
+--- a/examples/ratop/Makefile.in
++++ b/examples/ratop/Makefile.in
+@@ -54,7 +54,8 @@
+ DEFS = @DEFS@
+ COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@ @V_GEOIPDEP@ @V_PCRE@ @V_FTDEP@ @ZLIB@
+
+-CURSESLIB = @CURSESLIB@ @V_READLINE@
++CURSESLIB = @CURSESLIB@
++V_READLINE = @V_READLINE@
+
+ # Standard CFLAGS
+ CFLAGS = $(CCOPT) $(INCLS) $(DEFS)
+@@ -93,7 +94,7 @@
+ all: $(PROGS)
+
+ $(INSTALLBIN)/ratop: $(OBJ) $(LIB)
+- $(CC) $(CFLAGS) -o $@ $(OBJ) $(LDFLAGS) $(LIB) $(COMPATLIB) $(CURSESLIB)
++ $(CC) $(CFLAGS) -o $@ $(OBJ) $(LDFLAGS) $(LIB) $(COMPATLIB) $(CURSESLIB) $(V_READLINE)
+
+ CLEANFILES = $(OBJ) $(PROGS)
+
diff --git a/net-analyzer/argus-clients/metadata.xml b/net-analyzer/argus-clients/metadata.xml
new file mode 100644
index 000000000000..ca640803f2e3
--- /dev/null
+++ b/net-analyzer/argus-clients/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<use><flag name="ft">Enable support for flow packets through
+<pkg>net-analyzer/flow-tools</pkg></flag></use>
+</pkgmetadata>