summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-29 19:59:45 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-29 19:59:45 +0100
commit4469279ff2a80156301fba048c086e84ab6fcf58 (patch)
treee5ac915f8a4102ad80b19aada8ac64a132c697e7 /net-analyzer/arp-sk
parentnet-analyzer/ipcad: Port to EAPI 8 (diff)
downloadgentoo-4469279ff2a80156301fba048c086e84ab6fcf58.tar.gz
gentoo-4469279ff2a80156301fba048c086e84ab6fcf58.tar.bz2
gentoo-4469279ff2a80156301fba048c086e84ab6fcf58.zip
net-analyzer/arp-sk: Port to EAPI 8
Closes: https://bugs.gentoo.org/826826 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-analyzer/arp-sk')
-rw-r--r--net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild b/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild
index e18045a7f774..6b9187db0bbd 100644
--- a/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild
+++ b/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools epatch multilib
+inherit autotools
DESCRIPTION="A swiss knife tool for ARP"
HOMEPAGE="http://sid.rstack.org/arp-sk/"
@@ -18,11 +18,14 @@ RDEPEND="${DEPEND}"
DOCS=( ARP AUTHORS CONTRIB ChangeLog README TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-libnet1_2.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-libnet1_2.patch
+ default
sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
rm missing || die
- epatch_user
eautoreconf
}
@@ -31,5 +34,5 @@ src_install() {
default
# We don't need libcompat as it has a potential to clash with other packages.
- rm -fr "${D}"/usr/$(get_libdir)
+ rm -r "${ED}"/usr/$(get_libdir) || die
}