summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/arp-sk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/arp-sk')
-rw-r--r--net-analyzer/arp-sk/Manifest1
-rw-r--r--net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild34
-rw-r--r--net-analyzer/arp-sk/files/arp-sk-0.0.16-libnet1_2.patch50
-rw-r--r--net-analyzer/arp-sk/metadata.xml5
4 files changed, 90 insertions, 0 deletions
diff --git a/net-analyzer/arp-sk/Manifest b/net-analyzer/arp-sk/Manifest
new file mode 100644
index 000000000000..b244641df50a
--- /dev/null
+++ b/net-analyzer/arp-sk/Manifest
@@ -0,0 +1 @@
+DIST arp-sk-0.0.16.tgz 211636 SHA256 6e1c98ff5396dd2d1c95a0d8f08f85e51cf05b1ed85ea7b5bcf73c4ca5d301dd SHA512 d827ab5c701e1e3a6444dbe7e1e7c0a73ee2bfb2339a55fc7d3591ee8e9e9aadef4dfd4aaf331251fbe22d83c9b1135068e5afa6303eae934b3fd149ca0819a6 WHIRLPOOL 66e774c1c47c912132559067c5991c16bec4738b39d474a7a7b3d0011c4b17b1c09d4073843fd705b87cd30036c6a2cf9566c384a03a0dc177925d4293db938a
diff --git a/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild b/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild
new file mode 100644
index 000000000000..0a795a42185b
--- /dev/null
+++ b/net-analyzer/arp-sk/arp-sk-0.0.16-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib
+
+DESCRIPTION="A swiss knife tool for ARP"
+HOMEPAGE="http://sid.rstack.org/arp-sk/"
+SRC_URI="http://sid.rstack.org/arp-sk/files/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND=">=net-libs/libnet-1.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( ARP AUTHORS CONTRIB ChangeLog README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnet1_2.patch
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ rm missing || die
+ epatch_user
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # We don't need libcompat as it has a potential to clash with other packages.
+ rm -fr "${D}"/usr/$(get_libdir)
+}
diff --git a/net-analyzer/arp-sk/files/arp-sk-0.0.16-libnet1_2.patch b/net-analyzer/arp-sk/files/arp-sk-0.0.16-libnet1_2.patch
new file mode 100644
index 000000000000..1fac654c0d86
--- /dev/null
+++ b/net-analyzer/arp-sk/files/arp-sk-0.0.16-libnet1_2.patch
@@ -0,0 +1,50 @@
+--- a/configure.in
++++ b/configure.in
+@@ -114,47 +114,6 @@
+ AC_MSG_RESULT(yes) ]
+ )
+
+-dnl Now let's checck the version of libnet (1.1.x requirerd)
+-AC_MSG_CHECKING(for version 1.1.x of libnet)
+-AC_TRY_RUN([
+-#include "$NETINC/libnet.h"
+-#include <string.h>
+-int main()
+-{
+- return (strncmp(LIBNET_VERSION, "1.1.", 4));
+-}
+-],
+-[ AC_MSG_RESULT(yes)],
+-[ AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Bad libnet version found in $NETINC/libnet.h:
+-download libnet-1.1.x from http://www.packetfactory.net/projects/libnet/.
+-If you think this version of libnet is already installed on your system
+-tell arp-sk where it is using --with-libnet=DIR)
+-]
+-dnl ,
+-dnl [ v=(`sed -n /LIBNET_VERSION/p /usr/local/include/libnet.h | sed s/\"//g |awk '{print $3}'`)
+-dnl echo "v=$v"
+-dnl save_IFS="${IFS}"
+-dnl IFS=.
+-dnl vatb=(${v[0]})
+-dnl IFS=$save_IFS
+-dnl LIBNET_MAJOR=${vtab[0]}
+-dnl LIBNET_MINOR=${vtab[1]}
+-
+-dnl if [ $LIBNET_MAJOR==1 -a $LIBNET_MINOR==1 ]; then
+-dnl AC_MSG_RESULT(yes);
+-dnl else
+-dnl AC_MSG_RESULT(no)
+-dnl AC_MSG_ERROR(Bad libnet version:
+-
+-dnl $NETINC/libnet.h
+-
+-dnl download libnet-1.1.x from http://www.packetfactory.net/projects/libnet/.
+-dnl If you think this version of libnet id already installed on your system,
+-dnl tell arp-sk where it is using --with-libnet=DIR)
+-dnl fi
+-dnl ]
+-)
+
+
+ NETINC="-I$NETINC"
diff --git a/net-analyzer/arp-sk/metadata.xml b/net-analyzer/arp-sk/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/arp-sk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>