summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-16 08:44:41 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-16 08:44:41 +0100
commit01a199ffb61812fca148257607b949af23881324 (patch)
treefa276503656c105cc08719f2eb924768aec32613 /net-analyzer/arping/arping-2.16.ebuild
parentx11-misc/xfe: Use upstream patch (xfe bug #209). (diff)
downloadgentoo-01a199ffb61812fca148257607b949af23881324.tar.gz
gentoo-01a199ffb61812fca148257607b949af23881324.tar.bz2
gentoo-01a199ffb61812fca148257607b949af23881324.zip
net-analyzer/arping: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-analyzer/arping/arping-2.16.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.16.ebuild b/net-analyzer/arping/arping-2.16.ebuild
new file mode 100644
index 000000000000..24e684e3d10b
--- /dev/null
+++ b/net-analyzer/arping/arping-2.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit fcaps
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/iputils[arping(+)]
+"
+
+FILECAPS=( cap_net_raw /usr/sbin/arping )