summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-04 09:37:10 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-04 09:37:10 +0200
commit33956d88e67955f08b439685e5fe09f16cf3bcef (patch)
tree7701bae1bbd76127610e8e287c393805115c683a /net-analyzer/arping/arping-2.17.ebuild
parentapp-misc/gentoo: Version bump. (diff)
downloadgentoo-33956d88e67955f08b439685e5fe09f16cf3bcef.tar.gz
gentoo-33956d88e67955f08b439685e5fe09f16cf3bcef.tar.bz2
gentoo-33956d88e67955f08b439685e5fe09f16cf3bcef.zip
net-analyzer/arping: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer/arping/arping-2.17.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.17.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.17.ebuild b/net-analyzer/arping/arping-2.17.ebuild
new file mode 100644
index 000000000000..26043330ccca
--- /dev/null
+++ b/net-analyzer/arping/arping-2.17.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit fcaps
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/iputils[arping(+)]
+"
+
+FILECAPS=( cap_net_raw /usr/sbin/arping )