summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-11-10 06:53:31 +0100
committerJeroen Roovers <jer@gentoo.org>2015-11-10 06:53:31 +0100
commit32582f6f6f40abbc49aedafabd1aeb76dc89e91e (patch)
treea5c477d617b8b0b9d3d2936aed944005d6aff668 /net-analyzer/arping
parentwww-plugins/adobe-flash: Version bump. (diff)
downloadgentoo-32582f6f6f40abbc49aedafabd1aeb76dc89e91e.tar.gz
gentoo-32582f6f6f40abbc49aedafabd1aeb76dc89e91e.tar.bz2
gentoo-32582f6f6f40abbc49aedafabd1aeb76dc89e91e.zip
net-analyzer/arping: Add live ebuild.
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-analyzer/arping')
-rw-r--r--net-analyzer/arping/a.out0
-rw-r--r--net-analyzer/arping/arping-9999.ebuild29
2 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/arping/a.out b/net-analyzer/arping/a.out
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-analyzer/arping/a.out
diff --git a/net-analyzer/arping/arping-9999.ebuild b/net-analyzer/arping/arping-9999.ebuild
new file mode 100644
index 000000000000..e128982659cc
--- /dev/null
+++ b/net-analyzer/arping/arping-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils fcaps git-r3
+
+DESCRIPTION="ARP Ping"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+EGIT_REPO_URI="https://github.com/ThomasHabets/arping"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS=""
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/iputils[arping(+)]
+"
+
+FILECAPS=( cap_net_raw /usr/sbin/arping )
+
+src_prepare() {
+ eautoreconf
+}