summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-10 19:26:33 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-10 19:27:08 +0100
commit5bafe8c6a96dbadcf8867c0460d558dcbc2b2213 (patch)
treedc61f217a76e0dd66d4c3bd13e4e434e835fde25 /net-analyzer/bigeye
parentvirtual/libcrypt: Add multilib support. (diff)
downloadgentoo-5bafe8c6a96dbadcf8867c0460d558dcbc2b2213.tar.gz
gentoo-5bafe8c6a96dbadcf8867c0460d558dcbc2b2213.tar.bz2
gentoo-5bafe8c6a96dbadcf8867c0460d558dcbc2b2213.zip
net-analyzer/bigeye: Set CFLAGS=-fno-common
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=708996 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/bigeye')
-rw-r--r--net-analyzer/bigeye/bigeye-0.3-r4.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/net-analyzer/bigeye/bigeye-0.3-r4.ebuild b/net-analyzer/bigeye/bigeye-0.3-r4.ebuild
index e92408b8df42..b349042d1ded 100644
--- a/net-analyzer/bigeye/bigeye-0.3-r4.ebuild
+++ b/net-analyzer/bigeye/bigeye-0.3-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="network utility dump and simple honeypot utility"
HOMEPAGE="http://violating.us/projects/bigeye/"
@@ -27,6 +27,7 @@ src_prepare() {
}
src_compile() {
+ append-cflags -fcommon
$(tc-getCC) ${CFLAGS} ${LDFLAGS} src/bigeye.c src/emulate.c -o src/bigeye || die
}