summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/bwbar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/bwbar')
-rw-r--r--net-analyzer/bwbar/Manifest1
-rw-r--r--net-analyzer/bwbar/bwbar-1.2.3.ebuild26
-rw-r--r--net-analyzer/bwbar/files/bwbar-1.2.3-libpng15.patch19
-rw-r--r--net-analyzer/bwbar/metadata.xml5
4 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/bwbar/Manifest b/net-analyzer/bwbar/Manifest
new file mode 100644
index 000000000000..d9ab4bd216dc
--- /dev/null
+++ b/net-analyzer/bwbar/Manifest
@@ -0,0 +1 @@
+DIST bwbar-1.2.3.tar.bz2 30202 SHA256 d82f8ba7defbdb9ae6671cbd7a064597a2a717ee6eeb32df6093403e8a86d1c1 SHA512 cb534f50007db6e39aa134d0d9a08ec6935c8a393f8dd5ab80f3c6ef94048821e065cd6c1be80657a2d6338fd16a73dcc0f89f5b15aba9e3bd38f0737a6d43c4 WHIRLPOOL acc5b09305f1d4f827bdf11098f23c8e3b2353343b83166b6168e9d39c5233acdd10fbfa9b302346f02c42073e0196dc8593bdfc03c25cabcc75264bf178e679
diff --git a/net-analyzer/bwbar/bwbar-1.2.3.ebuild b/net-analyzer/bwbar/bwbar-1.2.3.ebuild
new file mode 100644
index 000000000000..681a9c7ec1d9
--- /dev/null
+++ b/net-analyzer/bwbar/bwbar-1.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="The kernel.org \"Current bandwidth utilization\" bar"
+HOMEPAGE="http://www.kernel.org/pub/software/web/bwbar/"
+SRC_URI="mirror://kernel/software/web/bwbar/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_install() {
+ dobin bwbar
+ dodoc README
+}
diff --git a/net-analyzer/bwbar/files/bwbar-1.2.3-libpng15.patch b/net-analyzer/bwbar/files/bwbar-1.2.3-libpng15.patch
new file mode 100644
index 000000000000..4d1bd67c6d34
--- /dev/null
+++ b/net-analyzer/bwbar/files/bwbar-1.2.3-libpng15.patch
@@ -0,0 +1,19 @@
+--- a/bwbar.c
++++ b/bwbar.c
+@@ -30,6 +30,7 @@
+ #include <alloca.h>
+ #include <getopt.h>
+ #include <png.h>
++#include <zlib.h>
+
+ void skipline(FILE *f)
+ {
+@@ -79,7 +80,7 @@
+ if ( !info_ptr )
+ goto barf;
+
+- if ( setjmp(png_ptr->jmpbuf) ) {
++ if ( setjmp(png_jmpbuf(png_ptr)) ) {
+ status = 1;
+ goto barf; /* libpng abort */
+ }
diff --git a/net-analyzer/bwbar/metadata.xml b/net-analyzer/bwbar/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/bwbar/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>