summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-14 07:42:16 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-14 07:42:16 +0100
commit02dd7e2aab8fdcba130db41f82fe0a8291b83787 (patch)
treeaf7da8305133c758f0d17f62b4df1dadb2bc0d16 /net-analyzer/cacti-spine/cacti-spine-1.0.5.ebuild
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-02dd7e2aab8fdcba130db41f82fe0a8291b83787.tar.gz
gentoo-02dd7e2aab8fdcba130db41f82fe0a8291b83787.tar.bz2
gentoo-02dd7e2aab8fdcba130db41f82fe0a8291b83787.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'net-analyzer/cacti-spine/cacti-spine-1.0.5.ebuild')
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.0.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.0.5.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.0.5.ebuild
new file mode 100644
index 000000000000..34727025866f
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}