summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-12-09 00:33:53 +0100
committerJeroen Roovers <jer@gentoo.org>2019-12-09 00:37:44 +0100
commit7d0638cac362dc66f43ada298157dadbd6748be5 (patch)
tree890ccc53a186105262bb40e10d66d5f5a99238f3 /net-analyzer/cacti-spine
parentmedia-libs/gst-plugins-good: stable 1.14.5 for ia64, bug #702246 (diff)
downloadgentoo-7d0638cac362dc66f43ada298157dadbd6748be5.tar.gz
gentoo-7d0638cac362dc66f43ada298157dadbd6748be5.tar.bz2
gentoo-7d0638cac362dc66f43ada298157dadbd6748be5.zip
net-analyzer/cacti-spine: Version 1.2.8
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.8.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index a3b4b47a055b..19b21a2440d7 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,3 +1,4 @@
DIST cacti-spine-1.1.38.tar.gz 805437 BLAKE2B 32d934f54e00d83e9807dd194a7cacf8d5526c8e5b84c44ffad201c07edcb117f862266843552299fe04cc780575b9b2dc7129a106a20bd709cb82844ade7812 SHA512 5409a690e89fcc74e1e87e34e1918cab27d1243825955eb8256a92f8e9658f312345c66b338a4a07a0e38c94e3275131cb4e58fb70e7b59837c0e6c47746e45e
DIST cacti-spine-1.2.6.tar.gz 106592 BLAKE2B 4c7f92e1c1e6061689a5a18cc73326e38b1ed275d443069bf5bb6ad0edb9429b4946096db650d9af73b11ec51f1bc8728420a5084847b4d468b1e13341655ea3 SHA512 6659a3694c38704e266efda40893ed8e1bc1c52f3ae93a66ad219043408dd77bfdbde55191982ed3cebdffce1f49faf3e487fb926c680ea9b1c6dd379e1b53fc
DIST cacti-spine-1.2.7.tar.gz 106764 BLAKE2B 3c880c5e7e736d6d3acf3dbd5aeba13ed457d92541616ff8ddd2e88182a93c6c46ecc7c4c2d5f16784c91cdef823febf8fffac4a7ff92cf7ee11f1fda129956f SHA512 9877d4bb4d17728c714add8d5b6e974a2d92115753bfc1b2737e2d435072138169d9e2486eddc9e25048a4a72767baeb64a5479f738c4d3e57d8f362c8e3f48e
+DIST cacti-spine-1.2.8.tar.gz 106799 BLAKE2B 480e2b74535696410298cdf6d7ca88d3724a6fead76542942d48c6f3cf0cd659eca07c5e12ddc62b67b37ae76cde62a52d2c436e8f81cfcfb4b072b4098d3d8e SHA512 2e174175ab4dc94089896bef49e30c7f51a84e48a402b7c43a5f794f8e37d23083065f521f91baafa51c844a7ff7494dd087384ff7c57893708f00f6f9d1eb15
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.8.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.8.ebuild
new file mode 100644
index 000000000000..8ca6122419f9
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}