summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-02 01:41:15 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-02 01:41:33 +0100
commit2eb484dfb0d50ddaf9051ec7d0930397b7bf7bc7 (patch)
treea363d2969a71fb1a20480a5caf410908ebc17677 /net-analyzer/cbm
parentkde-misc/playbar2: Switch to cmake.eclass (diff)
downloadgentoo-2eb484dfb0d50ddaf9051ec7d0930397b7bf7bc7.tar.gz
gentoo-2eb484dfb0d50ddaf9051ec7d0930397b7bf7bc7.tar.bz2
gentoo-2eb484dfb0d50ddaf9051ec7d0930397b7bf7bc7.zip
net-analyzer/cbm: Version 0.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/cbm')
-rw-r--r--net-analyzer/cbm/Manifest1
-rw-r--r--net-analyzer/cbm/cbm-0.2.ebuild34
-rw-r--r--net-analyzer/cbm/files/cbm-0.2-tinfo.patch21
3 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/cbm/Manifest b/net-analyzer/cbm/Manifest
index 5f869f61f0d1..b532c14ec13a 100644
--- a/net-analyzer/cbm/Manifest
+++ b/net-analyzer/cbm/Manifest
@@ -1 +1,2 @@
DIST cbm-0.1.tar.gz 310247 BLAKE2B 08d2b7c79795217e6f6e2c72bbf1a4e5af096ddd9ed76c9a61093cd790d7ef2429d2db3d94102c334f1433803d4b91cb297f57185b666554ce84eee5c2295322 SHA512 24bf6a4d68fed253977b965d7e5b6aff4fb9db502c47b4a2b3b36f8c2963c9648b78ae607e9753fe4792a73ddbc29b86b3a1acc3c431a9355b11ff348566add4
+DIST cbm-0.2.tar.gz 16043 BLAKE2B a5c041ac33b4694c2933bee0d71786896ec30d0735b921f34cfb6a247179709afd9fa6d90f0602869976f334391e8138830f538b18a08a7396f4049e26029b24 SHA512 ca9dbbd73e707dca3b7bf10201840de28b2b3956ce3cb2fc76e1b530caf6ff883eb437f8be0df1efe3b5d8398c4949ea00de4ba48ed26b27afa21cf445d5d076
diff --git a/net-analyzer/cbm/cbm-0.2.ebuild b/net-analyzer/cbm/cbm-0.2.ebuild
new file mode 100644
index 000000000000..970db519d022
--- /dev/null
+++ b/net-analyzer/cbm/cbm-0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Color Bandwidth Meter"
+HOMEPAGE="
+ http://www.isotton.com/software/unix/cbm/
+ https://github.com/resurrecting-open-source-projects/cbm
+"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/docbook-xml-dtd:4.4
+ app-text/xmlto
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/net-analyzer/cbm/files/cbm-0.2-tinfo.patch b/net-analyzer/cbm/files/cbm-0.2-tinfo.patch
new file mode 100644
index 000000000000..a719969eaaab
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.2-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,6 +37,7 @@
+ AC_CANONICAL_HOST
+
+ # Checks for libraries.
++PKG_CHECK_MODULES(ncurses,ncurses)
+
+ # Checks for header files.
+ AC_CHECK_HEADER(curses.h,[],[ AC_MSG_ERROR(curses.h not found or too old.) ], [])
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -24,7 +24,7 @@
+ cbm_SOURCES = cbm.cpp \
+ ErrnoError.hpp \
+ statistics.cpp statistics.hpp
+-cbm_LDADD = -lncurses widgets/libwidgets.la
++cbm_LDADD = $(ncurses_LIBS) widgets/libwidgets.la
+
+ distclean-local:
+ -rm -f *~ \