summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-01-26 22:40:54 -0500
committerZero_Chaos <zerochaos@gentoo.org>2016-01-26 22:41:18 -0500
commitb5e2630bd88a20efe5cfe1dfa13fee9e1f67a23d (patch)
tree27933b5a114bb648b4132277f4c12d5cfb9dfa04 /net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
parentMerge remote-tracking branch 'remotes/jasom/master' (diff)
downloadgentoo-b5e2630bd88a20efe5cfe1dfa13fee9e1f67a23d.tar.gz
gentoo-b5e2630bd88a20efe5cfe1dfa13fee9e1f67a23d.tar.bz2
gentoo-b5e2630bd88a20efe5cfe1dfa13fee9e1f67a23d.zip
net-analyzer/cloudshark: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer/cloudshark/cloudshark-1.0.4.ebuild')
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
new file mode 100644
index 000000000000..7f3e11186148
--- /dev/null
+++ b/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Easily upload your wireshark captures to CloudShark"
+HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
+SRC_URI="https://github.com/${PN}/wireshark-plugin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PDEPEND="net-analyzer/wireshark:=[lua]
+ net-misc/curl"
+
+S="${WORKDIR}/wireshark-plugin-${PV}"
+
+get_PV() {
+ local pv=$(best_version $1)
+ pv=${pv#$1-}; pv=${pv%-r*}
+ pv=${pv//_}; echo ${pv}
+}
+
+src_prepare() {
+ #cloudshark isn't meant to be installed systemwide, we fix that
+ epatch "${FILESDIR}"/cs_log_dir.patch
+
+ sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
+
+ #this enables cloudshark by DEFAULT on tshark, not desired
+ #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
+ doins cloudshark.lua json.lua
+ newins cloudshark_init.default cloudshark_init.lua
+ dodoc README.md
+}