summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch')
-rw-r--r--net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch b/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
new file mode 100644
index 000000000000..17ec33489c89
--- /dev/null
+++ b/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
@@ -0,0 +1,43 @@
+--- a/unix/Makefile
++++ b/unix/Makefile
+@@ -10,16 +10,14 @@
+ # debugging
+ # DFLAGS = -DTEST -DDEBUG
+ DFLAGS = -DGAPING_SECURITY_HOLE
+-CFLAGS = -O
++CFLAGS ?= -O
+ XFLAGS = # xtra cflags, set by systype targets
+ XLIBS = # xtra libs if necessary?
+ # -Bstatic for sunos, -static for gcc, etc. You want this, trust me.
+ STATIC =
+-CC = cc $(CFLAGS)
+-LD = $(CC) -s # linker; defaults to stripped executables
+ o = o # object extension
+
+-ALL = cryptcat
++all: cryptcat
+
+ ### BOGON-CATCHERS
+
+@@ -28,8 +26,8 @@
+
+ ### HARD TARGETS
+
+-cryptcat: netcat.c farm9crypt.o twofish2.o
+- $(LD) $(DFLAGS) $(XFLAGS) $(STATIC) -o cryptcat netcat.c farm9crypt.o twofish2.o $(XLIBS)
++cryptcat: netcat.o farm9crypt.o twofish2.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+ nc-dos:
+ @echo "DOS?! Maybe someday, but not now"
+@@ -115,10 +112,8 @@
+ make -e $(ALL) $(MFLAGS) XFLAGS='-DNEXT' STATIC=-Bstatic
+
+ farm9crypt.o: farm9crypt.cc farm9crypt.h
+- ${CC} -c farm9crypt.cc
+
+ twofish2.o: twofish2.cc twofish2.h
+- ${CC} -c twofish2.cc
+
+ # start with this for a new architecture, and see what breaks.
+ generic: