summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-18 10:07:11 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-19 21:00:50 +0000
commit8934040f393bc4859c93d567e4614497fdcf2115 (patch)
tree988927001de392fb1b2d58717abb70dd77b53310 /net-analyzer/fail2ban/fail2ban-0.9.4.ebuild
parentprofiles: Remove unused vmware mirror grou, bug 563736 (diff)
downloadgentoo-8934040f393bc4859c93d567e4614497fdcf2115.tar.gz
gentoo-8934040f393bc4859c93d567e4614497fdcf2115.tar.bz2
gentoo-8934040f393bc4859c93d567e4614497fdcf2115.zip
net-analyzer/fail2ban: apply changes from the 0.9.3 ebuild to 0.9.4
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1078
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.9.4.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.4.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.4.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.4.ebuild
index eae742b441e2..3f29cce3e92f 100644
--- a/net-analyzer/fail2ban/fail2ban-0.9.4.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.9.4.ebuild
@@ -17,8 +17,10 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="selinux systemd"
+# TODO support ipfw and ipfilter
RDEPEND="
kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( sys-freebsd/freebsd-pf )
net-misc/whois
virtual/logger
virtual/mta
@@ -33,24 +35,22 @@ REQUIRED_USE="systemd? ( !python_single_target_pypy )"
DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
-src_prepare() {
+python_prepare_all() {
# Replace /var/run with /run, but not in the top source directory
- sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -mindepth 2 -type f ) || die
+ find . -mindepth 2 -type f -exec \
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
- # Fix bashisms and do not direct useful output to /dev/null (bug #536320)
- # Remove global logrotate settings (bug #549856)
-
- distutils-r1_src_prepare
+ distutils-r1_python_prepare_all
}
python_test() {
- ${EPYTHON} bin/${PN}-testcases
+ "${PYTHON}" "bin/${PN}-testcases" || die "tests failed with ${EPYTHON}"
}
-src_install() {
- distutils-r1_src_install
+python_install_all() {
+ distutils-r1_python_install_all
- rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run
+ rm -r "${D}"/usr/share/doc/${PN} "${D}"/run || die
# not FILESDIR
newconfd files/gentoo-confd ${PN}
@@ -93,7 +93,6 @@ pkg_postinst() {
elog "If you want to use ${PN}'s persistent database, then reinstall"
elog "dev-lang/python with USE=sqlite"
fi
-
if has_version sys-apps/systemd[-python]; then
elog "If you want to track logins through sys-apps/systemd's"
elog "journal backend, then reinstall sys-apps/systemd with USE=python"