summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/fe3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/fe3d')
-rw-r--r--net-analyzer/fe3d/Manifest1
-rw-r--r--net-analyzer/fe3d/fe3d-0.11.2.ebuild55
-rw-r--r--net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch39
-rw-r--r--net-analyzer/fe3d/files/fe3d-0.11.2-coreutils.patch12
-rw-r--r--net-analyzer/fe3d/metadata.xml8
5 files changed, 115 insertions, 0 deletions
diff --git a/net-analyzer/fe3d/Manifest b/net-analyzer/fe3d/Manifest
new file mode 100644
index 000000000000..31293918db8d
--- /dev/null
+++ b/net-analyzer/fe3d/Manifest
@@ -0,0 +1 @@
+DIST fe3d_0.11.2-src.tar.bz2 322740 SHA256 8aef228d72c17d9dc060de15c751abbf12e1445f938f27c50cd33cb43d76d833 SHA512 989ca9d19f3f23c8c10afad978cc5226e190d6d0c28ea8402e1894598c136eda345258d96ffce3585af7a8cd993ce377f863a7c43620ceda8d3b0ce674eb616f WHIRLPOOL b5686ea9427149573be4b26a6786eda2ce091069ea22de9b607e30c46670553771c1d11379417ad8ccb29fd3706c151848b80aebe393a22b29353c4b91cee509
diff --git a/net-analyzer/fe3d/fe3d-0.11.2.ebuild b/net-analyzer/fe3d/fe3d-0.11.2.ebuild
new file mode 100644
index 000000000000..90d0b0e906b3
--- /dev/null
+++ b/net-analyzer/fe3d/fe3d-0.11.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="2.8"
+inherit autotools eutils wxwidgets
+
+if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
+ inherit subversion
+ SRC_URI=""
+ FE3D_REV=${BASH_REMATCH[2]}
+ ESVN_REPO_URI="http://svn.icapsid.net/fe3d/fe3d/branches/fe3d_0.11/@${FE3D_REV}"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}-src.tar.bz2"
+fi
+
+DESCRIPTION="A 3D visualization tool for network security information"
+HOMEPAGE="http://projects.icapsid.net/fe3d/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 x86"
+
+DOCS=( AUTHORS doc/{ChangeLog,README}.txt )
+
+RDEPEND="
+ >=dev-libs/xerces-c-2.7
+ net-analyzer/nmap
+ x11-libs/wxGTK:2.8[opengl]
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_prepare() {
+ need-wxwidgets unicode
+
+ epatch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-coreutils.patch
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ ewarn "This package has known issues:"
+ ewarn "1. The radius of the geometry nodes is wrong, causing overlap"
+ ewarn "2. Earth (and other) textures are upside down"
+ ewarn "3. This package contains some minor memory leaks"
+ echo
+ elog "Example using a nmap log:"
+ elog "/usr/bin/nmap -oX test.xml -O --osscan_limit 192.168.0.0/24"
+ elog "/usr/bin/fe3d test.xml"
+}
diff --git a/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch b/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch
new file mode 100644
index 000000000000..63d475194162
--- /dev/null
+++ b/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch
@@ -0,0 +1,39 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,16 +46,15 @@
+ ])
+ fi
+
+-CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
+-CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
+-CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
+-LIBS="$LIBS $WX_LIBS"
++#CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
++#CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
++#CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
++#LIBS="$LIBS $WX_LIBS"
+
+ AM_CPPFLAGS="$AM_CPPFLAGS $GL_CFLAGS $GLU_CFLAGS"
+-AM_LDFLAGS="$AM_LDFLAGS $GL_LIBS $GLU_LIBS"
+ AC_SUBST([AM_CPPFLAGS])
+ AC_SUBST([AM_LDFLAGS])
+-AC_SUBST([$PREFIX])
++#AC_SUBST([$PREFIX])
+
+ AC_OUTPUT
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,8 +1,10 @@
+-fe3d_CPPFLAGS = -DFE_DATA_DIR="\"@datadir@/@PACKAGE@/\""
++fe3d_CPPFLAGS = -DFE_DATA_DIR="\"@datadir@/@PACKAGE@/\"" @WX_CPPFLAGS@
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src/include
+ bin_PROGRAMS = fe3d
+ fe3d_SOURCES = fe_config.cpp fe_core.cpp fe_draw.cpp fe_events.cpp fe_host.cpp fe_hosts.cpp fe_match.cpp fe_node.cpp fe_os_rgx.cpp fe_port.cpp fe_root_node.cpp fe_tools.cpp geo_cache.cpp gl_util.cpp libfe3d.cpp nmap_parser.cpp tex_cache.cpp wxfe3d_app.cpp wxfe3d_frame.cpp wxfe3d_glcanvas.cpp ui_nmap_ctrl.cpp ./gui/fe3d_ui.cpp ./regexp/Matcher.cpp ./regexp/Pattern.cpp ./regexp/WCMatcher.cpp ./regexp/WCPattern.cpp
+-
++fe3d_CFLAGS = @WX_CFLAGS@
++fe3d_CXXFLAGS = @WX_CXXFLAGS_ONLY@
++fe3d_LDADD = @GLU_LIBS@ @WX_LIBS@
+ fe3ddir = @datadir@/@PACKAGE@
+ fe3d_imgdir = @datadir@/@PACKAGE@/img
+ fe3d_DATA = $(top_srcdir)/data/*
diff --git a/net-analyzer/fe3d/files/fe3d-0.11.2-coreutils.patch b/net-analyzer/fe3d/files/fe3d-0.11.2-coreutils.patch
new file mode 100644
index 000000000000..547d86fb5cab
--- /dev/null
+++ b/net-analyzer/fe3d/files/fe3d-0.11.2-coreutils.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/330047
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -5,5 +5,5 @@
+
+ fe3ddir = @datadir@/@PACKAGE@
+ fe3d_imgdir = @datadir@/@PACKAGE@/img
+-fe3d_DATA = $(top_srcdir)/data/*
+-fe3d_img_DATA = $(top_srcdir)/data/img/*
++fe3d_DATA = $(top_srcdir)/data/*.xml
++fe3d_img_DATA = $(top_srcdir)/data/img/*.png
diff --git a/net-analyzer/fe3d/metadata.xml b/net-analyzer/fe3d/metadata.xml
new file mode 100644
index 000000000000..5fd4d3b42253
--- /dev/null
+++ b/net-analyzer/fe3d/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">fe3d</remote-id>
+ </upstream>
+</pkgmetadata>