summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-03 17:29:18 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-03 17:29:18 +0200
commit7b21eb894c1ed0244bbb88bd5211fddc6b04cae6 (patch)
treebab6ea0849da8f55b8f49c513bde7eaf6d224e31 /net-analyzer/flow-tools/flow-tools-0.68.5.1-r11.ebuild
parentacct-user/flows: Add user for net-analyzer/flow-tools (diff)
downloadgentoo-7b21eb894c1ed0244bbb88bd5211fddc6b04cae6.tar.gz
gentoo-7b21eb894c1ed0244bbb88bd5211fddc6b04cae6.tar.bz2
gentoo-7b21eb894c1ed0244bbb88bd5211fddc6b04cae6.zip
net-analyzer/flow-tools: [QA] Port to GLEP 81
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/flow-tools/flow-tools-0.68.5.1-r11.ebuild')
-rw-r--r--net-analyzer/flow-tools/flow-tools-0.68.5.1-r11.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r11.ebuild b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r11.ebuild
new file mode 100644
index 000000000000..d1f4fc95e62a
--- /dev/null
+++ b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r11.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="library and programs to process reports from NetFlow data"
+HOMEPAGE="https://code.google.com/p/flow-tools/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug libressl mysql postgres ssl static-libs"
+
+RDEPEND="
+ acct-group/flows
+ acct-user/flows
+ sys-apps/tcp-wrappers
+ sys-libs/zlib
+ mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql:* )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison"
+
+DOCS=( ChangeLog README SECURITY TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-run.patch
+ "${FILESDIR}"/${P}-syslog.patch
+ "${FILESDIR}"/${P}-openssl11.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(usex mysql --with-mysql '') \
+ $(usex postgres --with-postgresql=yes --with-postgresql=no) \
+ $(usex ssl --with-openssl '') \
+ --sysconfdir=/etc/flow-tools
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ exeinto /var/lib/flows/bin
+ doexe "${FILESDIR}"/linkme
+
+ keepdir /var/lib/flows/ft
+
+ newinitd "${FILESDIR}/flowcapture.initd" flowcapture
+ newconfd "${FILESDIR}/flowcapture.confd" flowcapture
+
+ fowners flows:flows /var/lib/flows
+ fowners flows:flows /var/lib/flows/bin
+ fowners flows:flows /var/lib/flows/ft
+
+ fperms 0755 /var/lib/flows
+ fperms 0755 /var/lib/flows/bin
+}