summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-10-22 13:14:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-10-22 13:14:51 +0200
commit144db59dbae42a702307c53abc5dcef5136df9f5 (patch)
treea094350e4e19310628c2b5ea32f5e56524049b52 /net-analyzer/fping/fping-3.13.ebuild
parentDrop deprecated usage of DISTUTILS_NO_PARALLEL_BUILD (diff)
downloadgentoo-144db59dbae42a702307c53abc5dcef5136df9f5.tar.gz
gentoo-144db59dbae42a702307c53abc5dcef5136df9f5.tar.bz2
gentoo-144db59dbae42a702307c53abc5dcef5136df9f5.zip
net-analyzer/fping: Bump to version 3.13
Package-Manager: portage-2.2.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-analyzer/fping/fping-3.13.ebuild')
-rw-r--r--net-analyzer/fping/fping-3.13.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/fping/fping-3.13.ebuild b/net-analyzer/fping/fping-3.13.ebuild
new file mode 100644
index 000000000000..22d0f98776e8
--- /dev/null
+++ b/net-analyzer/fping/fping-3.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="http://fping.org/"
+SRC_URI="http://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 suid"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ if use suid ; then
+ fperms u+s /usr/sbin/fping
+ use ipv6 && fperms u+s /usr/sbin/fping6
+ fi
+}