summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 00:02:06 -0400
committerSam James <sam@gentoo.org>2024-03-25 09:20:46 +0000
commit543633502616d4171476f40e5770b52df9e64bac (patch)
tree1c2263483c175bfa39c94d9a48c4233cf5bee707 /net-analyzer/gspoof/gspoof-3.2-r3.ebuild
parentnet-libs/libnet: make sure elibtoolize is applied (diff)
downloadgentoo-543633502616d4171476f40e5770b52df9e64bac.tar.gz
gentoo-543633502616d4171476f40e5770b52df9e64bac.tar.bz2
gentoo-543633502616d4171476f40e5770b52df9e64bac.zip
net-analyzer/gspoof: mark as LTO-unsafe
The release is from 2003 and no activity since then. No hope of reporting a bug upstream being worthwhile, and it is *sourceforge*. Closes: https://bugs.gentoo.org/861158 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/gspoof/gspoof-3.2-r3.ebuild')
-rw-r--r--net-analyzer/gspoof/gspoof-3.2-r3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-analyzer/gspoof/gspoof-3.2-r3.ebuild b/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
index 0dc610e0e3d7..b44beb880250 100644
--- a/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
+++ b/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop
+inherit autotools desktop flag-o-matic
DESCRIPTION="A simple GTK/command line TCP/IP packet generator"
HOMEPAGE="http://gspoof.sourceforge.net/"
@@ -31,6 +31,17 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/861158
+ #
+ # Upstream sourceforge is dead. Software last updated in December 2003.
+ # No bug filed.
+ filter-lto
+
+ default
+}
+
src_compile() {
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}