summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper KoƂodziej <kacper@kolodziej.in>2017-10-12 22:05:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-22 18:58:19 +0200
commitad109216e445e652afa5ee98402ceeea856a584c (patch)
tree2dc11f3a80a4a83d9bd7cc2df3a97e9dbebf454f /net-analyzer/hexinject/hexinject-1.6.ebuild
parentwww-client/elinks: sync with live ebuild. (diff)
downloadgentoo-ad109216e445e652afa5ee98402ceeea856a584c.tar.gz
gentoo-ad109216e445e652afa5ee98402ceeea856a584c.tar.bz2
gentoo-ad109216e445e652afa5ee98402ceeea856a584c.zip
net-analyzer/hexinject: add version 1.6.
Package-Manager: Portage-2.3.11, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5931
Diffstat (limited to 'net-analyzer/hexinject/hexinject-1.6.ebuild')
-rw-r--r--net-analyzer/hexinject/hexinject-1.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/hexinject-1.6.ebuild b/net-analyzer/hexinject/hexinject-1.6.ebuild
new file mode 100644
index 000000000000..5d8011ced352
--- /dev/null
+++ b/net-analyzer/hexinject/hexinject-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Network packet sniffer and injector"
+HOMEPAGE="http://hexinject.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools experimental"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ experimental? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ append-cflags -std=gnu89
+ tc-export CC
+}
+
+src_install() {
+ dobin hexinject
+ use tools && dobin hex2raw prettypacket
+ use experimental && dobin packets.tcl
+ einstalldocs
+}