summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 08:03:15 +0000
committerSam James <sam@gentoo.org>2021-03-22 08:09:22 +0000
commit9cff4f503b6275ac1d3cd5298a71aa39ae965419 (patch)
treeeba3fc7ebcd0f768c6f8b000d176aa896e1e2c18 /net-analyzer/httping
parentdev-python/intreehooks: Correct HOMEPAGE (diff)
downloadgentoo-9cff4f503b6275ac1d3cd5298a71aa39ae965419.tar.gz
gentoo-9cff4f503b6275ac1d3cd5298a71aa39ae965419.tar.bz2
gentoo-9cff4f503b6275ac1d3cd5298a71aa39ae965419.zip
net-analyzer/httping: don't assume ncurses is built with unicode support
A fun variant/difference from the usual tinfo bugs. Closes: https://bugs.gentoo.org/731950 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/httping-2.5.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-analyzer/httping/httping-2.5.ebuild b/net-analyzer/httping/httping-2.5.ebuild
index b4f856e559ba..5a90ceb79102 100644
--- a/net-analyzer/httping/httping-2.5.ebuild
+++ b/net-analyzer/httping/httping-2.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="http protocol ping-like program"
HOMEPAGE="http://www.vanheusden.com/httping/"
@@ -43,13 +43,19 @@ src_prepare() {
mkdir nl || die
mv httping-nl.1 nl/httping.1 || die
fi
+
}
src_configure() {
# not an autotools script
echo > makefile.inc || die
- use ncurses && LDFLAGS+=" $( $( tc-getPKG_CONFIG ) --libs ncurses )"
+ if use ncurses ; then
+ local ncurses_flags="$($(tc-getPKG_CONFIG) --libs ncurses)"
+
+ sed -i -e "s/-lncursesw/${ncurses_flags}/" Makefile || die
+ append-ldflags "${ncurses_flags}"
+ fi
}
src_compile() {