summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ipband/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ipband/files')
-rw-r--r--net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch20
-rw-r--r--net-analyzer/ipband/files/ipband-0.8.1-postfix.patch13
-rw-r--r--net-analyzer/ipband/files/ipband-init25
3 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch b/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
new file mode 100644
index 000000000000..e3929da8cfb4
--- /dev/null
+++ b/net-analyzer/ipband/files/ipband-0.8.1-gentoo.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,6 @@
+ CPPFLAGS=-I/usr/include/pcap
+ LIBS=-lpcap
+ CFLAGS := -Wall $(CFLAGS)
+-CC=gcc
+
+ ifndef PREFIX
+ PREFIX=/usr
+@@ -49,8 +48,7 @@
+ all: $(BIN)
+
+ $(BIN): $(OBJ_C)
+- $(CC) -o $(BIN) $(OBJ_C) $(LIBS) $(CFLAGS)
+- strip $(BIN)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ_C) $(LIBS)
+
+ install-strip: install
+
diff --git a/net-analyzer/ipband/files/ipband-0.8.1-postfix.patch b/net-analyzer/ipband/files/ipband-0.8.1-postfix.patch
new file mode 100644
index 000000000000..9db8313afb30
--- /dev/null
+++ b/net-analyzer/ipband/files/ipband-0.8.1-postfix.patch
@@ -0,0 +1,13 @@
+--- a/ipband.sample.conf
++++ b/ipband.sample.conf
+@@ -61,7 +61,10 @@
+ # MTA string. Default is "/usr/sbin/sendmail -t -ba". Change it to
+ # whatever runs MTA of your choice. Note that the stringis tokenized and
+ # passed to exec(), so that shell's metacharacters are not interpreted.
++# Sendmail
+ #mtastring "/usr/sbin/sendmail -t -ba"
++# Postfix
++#mtastring "/usr/sbin/sendmail -t"
+
+ # Default number of subnet mask bits.
+ #maskbits 24
diff --git a/net-analyzer/ipband/files/ipband-init b/net-analyzer/ipband/files/ipband-init
new file mode 100644
index 000000000000..edfef8a11057
--- /dev/null
+++ b/net-analyzer/ipband/files/ipband-init
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ipband"
+ start-stop-daemon --start --exec /usr/bin/ipband -- -F > /dev/null
+ if [ $? -ne 0 ]; then
+ ewarn "Check settings in /etc/ipband.conf"
+ eend 1
+ else
+ eend 0
+ fi
+}
+
+stop() {
+ ebegin "Stopping ipband"
+ start-stop-daemon --stop --exec /usr/bin/ipband
+ eend $?
+}