summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-12-24 06:34:35 +0000
committerSam James <sam@gentoo.org>2021-12-24 06:47:02 +0000
commit93c84c844c18bffebfc7751628cfac0666f4429d (patch)
treedb9d245d5b943dc603278cd03753c8a97151cf36 /net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch
parentdev-util/cargo-c: drop versions (diff)
downloadgentoo-93c84c844c18bffebfc7751628cfac0666f4429d.tar.gz
gentoo-93c84c844c18bffebfc7751628cfac0666f4429d.tar.bz2
gentoo-93c84c844c18bffebfc7751628cfac0666f4429d.zip
net-analyzer/linkchecker: bump to 10.1.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch')
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch b/net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch
new file mode 100644
index 000000000000..f0132a8a8089
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-10.1.0-version.patch
@@ -0,0 +1,32 @@
+diff --git a/setup.py b/setup.py
+index c00bdc0..8493d09 100755
+--- a/setup.py
++++ b/setup.py
+@@ -56,6 +56,7 @@ else:
+
+ # the application name
+ AppName = "LinkChecker"
++AppVersion = "LINKCHECKER_VERSION"
+ Description = "check links in web documents or full websites"
+
+ RELEASE_DATE_FILE = "_release_date"
+@@ -340,10 +341,7 @@ if os.name == "posix":
+
+ setup(
+ name=AppName,
+- use_scm_version={
+- "local_scheme": "node-and-timestamp",
+- "version_scheme": "post-release",
+- },
++ version=AppVersion,
+ description=Description,
+ keywords="link,url,site,checking,crawling,verification,validation",
+ author=myname,
+@@ -383,7 +381,6 @@ setup(
+ options={},
+ # Requirements, usable with setuptools or the new Python packaging module.
+ python_requires=">= 3.6",
+- setup_requires=["setuptools_scm"],
+ install_requires=[
+ "importlib_metadata;python_version<'3.8'",
+ "requests >= 2.4",