summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagios-check_dnssec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagios-check_dnssec')
-rw-r--r--net-analyzer/nagios-check_dnssec/Manifest1
-rw-r--r--net-analyzer/nagios-check_dnssec/metadata.xml16
-rw-r--r--net-analyzer/nagios-check_dnssec/nagios-check_dnssec-0.1_p28.ebuild31
3 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_dnssec/Manifest b/net-analyzer/nagios-check_dnssec/Manifest
new file mode 100644
index 000000000000..61ce37706042
--- /dev/null
+++ b/net-analyzer/nagios-check_dnssec/Manifest
@@ -0,0 +1 @@
+DIST check_dnssec-0.1_p28.tar.bz2 73458 SHA256 fedc867447f17299a4bb45c406f99483b0f09689b2a5fbbd3e29926f109952ea SHA512 e99b155f38963858750443f3cf834e4505f871cb06bbfabf07ade1b333b18507b9364e7250118ed5ee4a2134e2a45ee68b6386a9f3b0cb30a0bb02a4a6e263fa WHIRLPOOL 5510bfc17b2cd6e70d9361a44d19af9c7b40823da163c9b92edbc593fed69209127f56e72c239389c750688a4a0ef3ed0b77bcb8f27a6d4328c7130593cf8360
diff --git a/net-analyzer/nagios-check_dnssec/metadata.xml b/net-analyzer/nagios-check_dnssec/metadata.xml
new file mode 100644
index 000000000000..f54283e06f33
--- /dev/null
+++ b/net-analyzer/nagios-check_dnssec/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>andrew@ahamilto.net</email>
+ <name>Andrew Hamilton</name>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <herd>sysadmin</herd>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-check_dnssec/nagios-check_dnssec-0.1_p28.ebuild b/net-analyzer/nagios-check_dnssec/nagios-check_dnssec-0.1_p28.ebuild
new file mode 100644
index 000000000000..ba95859c44e9
--- /dev/null
+++ b/net-analyzer/nagios-check_dnssec/nagios-check_dnssec-0.1_p28.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+DESCRIPTION="check_dnssec is a set of Nagios plugins to monitor DNSSEC services"
+HOMEPAGE="https://svn.durchmesser.ch/trac/check_dnssec"
+
+MY_P=${P/nagios-/}
+
+# No upstream tarballs, tagged releaess in SVN only.
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="net-analyzer/nagios-plugins
+ net-libs/ldns"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ eautoreconf
+}
+
+DOCS=( ChangeLog README AUTHORS )