summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2022-02-20 09:22:54 +0100
committerMichael Orlitzky <mjo@gentoo.org>2022-02-23 07:58:32 -0500
commit643d480a4c984f2751201d808079060c593ae2b4 (patch)
treed0189d5e9607c68473b948ef7bcaced75b3c07e5 /net-analyzer/nagios-check_rbl
parentmail-filter/opendkim: update sendmail/libmilter dependency. (diff)
downloadgentoo-643d480a4c984f2751201d808079060c593ae2b4.tar.gz
gentoo-643d480a4c984f2751201d808079060c593ae2b4.tar.bz2
gentoo-643d480a4c984f2751201d808079060c593ae2b4.zip
net-analyzer/nagios-check_rbl: bump to v1.6.3 and EAPI=8.
Closes: https://github.com/gentoo/gentoo/pull/24281 Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer/nagios-check_rbl')
-rw-r--r--net-analyzer/nagios-check_rbl/Manifest1
-rw-r--r--net-analyzer/nagios-check_rbl/nagios-check_rbl-1.6.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_rbl/Manifest b/net-analyzer/nagios-check_rbl/Manifest
index 1b3800e794d7..eae4701c7ccc 100644
--- a/net-analyzer/nagios-check_rbl/Manifest
+++ b/net-analyzer/nagios-check_rbl/Manifest
@@ -1 +1,2 @@
DIST check_rbl-1.4.1.tar.gz 47585 BLAKE2B 24979d1579ef46f6d0626700bb8b9aa3f3acd4b422398ecbfa98909248fd6ffe61a763e377e7942d3078d8b91488f3fc0e2ab25f7c4821bcfa5cde08d000bd5c SHA512 3023aab6ba42dec46cb93eb2ef15e1998a1b3226bd1f143441e14a4271279ac9b24b85b9fc41a382eb203e5d2846b7f4ea4fe27db99d75b104d9182ea53079cb
+DIST check_rbl-1.6.3.tar.gz 50250 BLAKE2B cdaaf7252871c6a2cf34a1cacef36251b8526b73f4edb73fc1611a3426f350523928532bc78068438b8e71ec0e023da46749673aa5e9e1d5c6cd8b889f330305 SHA512 2fc84089eb9e41657f522aa7813776b3d46811759e177d031ff5d2f737d63c00897d50d5d878c1e5d5368ca1dde0b173e81b8a6f16fbb970270ef63d988add9b
diff --git a/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.6.3.ebuild b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.6.3.ebuild
new file mode 100644
index 000000000000..ada2a30fe7af
--- /dev/null
+++ b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.6.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Monitor whether or not a host is blacklisted"
+HOMEPAGE="https://github.com/matteocorti/check_rbl"
+
+MY_P="${P/nagios-/}"
+SRC_URI="https://github.com/matteocorti/check_rbl/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+# No, this is not redundant -- see bug 627082.
+RESTRICT=test
+
+# The package's INSTALL/Makefile.PL files specify its dependencies.
+#
+# * Data::Validate::Domain (dev-perl/Data-Validate-Domain)
+# * Data::Validate::IP (dev-perl/Data-Validate-IP)
+# * IO::Select (dev-lang/perl)
+# * Monitoring::Plugin (dev-perl/Monitoring-Plugin)
+# * Monitoring::Plugin::Getopt (dev-perl/Monitoring-Plugin)
+# * Monitoring::Plugin::Threshold (dev-perl/Monitoring-Plugin)
+# * Net::DNS (dev-perl/Net-DNS)
+# * Net::IP (dev-perl/Net-IP)
+# * Readonly (dev-perl/Readonly)
+# * Socket (virtual/perl-Socket)
+#
+RDEPEND="dev-lang/perl
+ dev-perl/Data-Validate-Domain
+ dev-perl/Data-Validate-IP
+ dev-perl/Monitoring-Plugin
+ dev-perl/Net-DNS
+ dev-perl/Net-IP
+ dev-perl/Readonly
+ virtual/perl-Socket"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ perl Makefile.PL INSTALLDIRS=vendor || die
+}
+
+src_install() {
+ default
+
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+
+ # It's simplest to move this file after it's been installed.
+ dodir "${nagiosplugindir}"
+ mv "${D}"/usr/bin/check_rbl "${D}"/"${nagiosplugindir}" || die
+}