summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-02-16 17:18:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-02-16 18:34:43 +0100
commit2a99e4f97d86fd351f5ce4c31faeb62a98d17c5b (patch)
tree86d79f9ea44c595ad268dccc288ddd054c01b26a /net-analyzer/nbtscan
parentmedia-libs/libshout: remove unused patch(es) (diff)
downloadgentoo-2a99e4f97d86fd351f5ce4c31faeb62a98d17c5b.tar.gz
gentoo-2a99e4f97d86fd351f5ce4c31faeb62a98d17c5b.tar.bz2
gentoo-2a99e4f97d86fd351f5ce4c31faeb62a98d17c5b.zip
net-analyzer/nbtscan: remove unused patch(es)
Closes: https://github.com/gentoo/gentoo/pull/19490 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-analyzer/nbtscan')
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch15
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch42
-rw-r--r--net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch119
3 files changed, 0 insertions, 176 deletions
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch
deleted file mode 100644
index dbf2457bc29f..000000000000
--- a/net-analyzer/nbtscan/files/nbtscan-1.5.1-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -11,10 +11,10 @@
- BINDIR = @bindir@
-
- nbtscan: $(OBJECTS)
-- $(CC) $(CFLAGS) -o nbtscan $(OBJECTS) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o nbtscan $(OBJECTS) $(LIBS)
-
- install:
-- $(INSTALL) $(TARGET) $(BINDIR)/$(TARGET)
-+ $(INSTALL) $(TARGET) $(DESTDIR)/$(BINDIR)/$(TARGET)
-
- nbtscan.o: nbtscan.c statusq.h range.h list.h
- $(CC) $(CFLAGS) $(DEFS) -c nbtscan.c
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch
deleted file mode 100644
index a585d4495fb5..000000000000
--- a/net-analyzer/nbtscan/files/nbtscan-1.5.1-includes-declarations.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/list.h
-+++ b/list.h
-@@ -19,3 +19,5 @@
- int compare(struct list_item* item1, struct list_item* item2);
-
- int insert(struct list* lst, unsigned long content);
-+
-+int in_list(struct list* lst, unsigned long content);
---- a/nbtscan.c
-+++ b/nbtscan.c
-@@ -5,6 +5,8 @@
- #include <stdlib.h>
- #include <sys/time.h>
- #include <string.h>
-+#include <ctype.h>
-+#include <unistd.h>
- #if HAVE_STDINT_H
- #include <stdint.h>
- #endif
---- a/statusq.h
-+++ b/statusq.h
-@@ -103,4 +103,10 @@
- char* service_name;
- } nb_service_t ;
-
-+char* getnbservicename(my_uint8_t service, int unique, char* name);
-+
-+struct nb_host_info* parse_response(char* buff, int buffsize);
-+
-+int send_query(int sock, struct in_addr dest_addr, my_uint32_t rtt_base);
-+
- #endif /* STATUSQ_H */
---- a/statusq.c
-+++ b/statusq.c
-@@ -29,6 +29,7 @@
- #include <sys/time.h>
- #include "statusq.h"
- #include <string.h>
-+#include <ctype.h>
- #include <stdio.h>
- #include <stddef.h>
- #include "errors.h"
diff --git a/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch b/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch
deleted file mode 100644
index 4aca976dcd38..000000000000
--- a/net-analyzer/nbtscan/files/nbtscan-1.5.1-script-whitespace.patch
+++ /dev/null
@@ -1,119 +0,0 @@
---- a/nbtscan.c
-+++ b/nbtscan.c
-@@ -86,7 +86,7 @@
- int d_print_hostinfo(struct in_addr addr, const struct nb_host_info* hostinfo) {
- int i;
- unsigned char service; /* 16th byte of NetBIOS name */
-- char name[16];
-+ char comp_name[16];
-
- printf("\nPacket dump for Host %s:\n\n", inet_ntoa(addr));
- if(hostinfo->is_broken) printf("Incomplete packet, %d bytes long.\n", hostinfo->is_broken);
-@@ -110,9 +110,9 @@
- printf("Names received:\n");
- for(i=0; i< hostinfo->header->number_of_names; i++) {
- service = hostinfo->names[i].ascii_name[15];
-- strncpy(name, hostinfo->names[i].ascii_name, 15);
-- name[16]=0;
-- printf("%-17s Service: 0x%02x Flags: 0x%04x\n", name, service, hostinfo->names[i].rr_flags);
-+ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-+ comp_name[15]=0;
-+ printf("%-17s Service: 0x%02x Flags: 0x%04x\n", comp_name, service, hostinfo->names[i].rr_flags);
- }
- };
-
-@@ -147,9 +147,9 @@
-
-
- int v_print_hostinfo(struct in_addr addr, const struct nb_host_info* hostinfo, char* sf, int hr) {
-- int i, unique;
-+ int i, j, unique;
- my_uint8_t service; /* 16th byte of NetBIOS name */
-- char name[16];
-+ char comp_name[16];
- char* sname;
-
- if(!sf) {
-@@ -163,20 +163,27 @@
- if(hostinfo->header && hostinfo->names) {
- for(i=0; i< hostinfo->header->number_of_names; i++) {
- service = hostinfo->names[i].ascii_name[15];
-- strncpy(name, hostinfo->names[i].ascii_name, 15);
-- name[16]=0;
-+ strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-+
-+ // Eliminate trailing spaces
-+ for(j=0; j < 15; j++) {
-+ if (comp_name[j] == ' ')
-+ break;
-+ }
-+ comp_name[j] = 0;
-+
- unique = !(hostinfo->names[i].rr_flags & 0x0080);
- if(sf) {
-- printf("%s%s%s%s", inet_ntoa(addr), sf, name, sf);
-- if(hr) printf("%s\n", (char*)getnbservicename(service, unique, name));
-+ printf("%s%s%s%s", inet_ntoa(addr), sf, comp_name, sf);
-+ if(hr) printf("%s\n", (char*)getnbservicename(service, unique, comp_name));
- else {
- printf("%02x", service);
- if(unique) printf("U\n");
- else printf("G\n");
- }
- } else {
-- printf("%-17s", name);
-- if(hr) printf("%s\n", (char*)getnbservicename(service, unique, name));
-+ printf("%-17s", comp_name);
-+ if(hr) printf("%s\n", (char*)getnbservicename(service, unique, comp_name));
- else {
- printf("<%02x>", service);
- if(unique) printf(" UNIQUE\n");
-@@ -199,7 +206,7 @@
- };
-
- int print_hostinfo(struct in_addr addr, struct nb_host_info* hostinfo, char* sf) {
-- int i;
-+ int i,j;
- unsigned char service; /* 16th byte of NetBIOS name */
- char comp_name[16], user_name[16];
- int is_server=0;
-@@ -215,7 +222,13 @@
- if(service == 0 && unique && first_name) {
- /* Unique name, workstation service - this is computer name */
- strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-- comp_name[15] = 0;
-+
-+ // Eliminate trailing spaces
-+ for(j=0; j < 15; j++) {
-+ if (comp_name[j] == ' ')
-+ break;
-+ }
-+ comp_name[j] = 0;
- first_name = 0;
- };
- if(service == 0x20 && unique) {
-@@ -252,7 +265,7 @@
- /* If l is true adds #PRE to each line of output (for lmhosts) */
-
- int l_print_hostinfo(struct in_addr addr, struct nb_host_info* hostinfo, int l) {
-- int i;
-+ int i,j;
- unsigned char service; /* 16th byte of NetBIOS name */
- char comp_name[16];
- int is_server=0;
-@@ -268,7 +281,13 @@
- if(service == 0 && unique && first_name) {
- /* Unique name, workstation service - this is computer name */
- strncpy(comp_name, hostinfo->names[i].ascii_name, 15);
-- comp_name[15]=0;
-+
-+ // Eliminate trailing spaces
-+ for(j=0; j < 15; j++) {
-+ if (comp_name[j] == ' ')
-+ break;
-+ }
-+ comp_name[j] = 0;
- first_name = 0;
- };
- };
-