summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ndoutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ndoutils')
-rw-r--r--net-analyzer/ndoutils/Manifest2
-rwxr-xr-xnet-analyzer/ndoutils/files/ndo2db.init-nagios325
-rw-r--r--net-analyzer/ndoutils/files/ndoutils-1.4_beta9-asprintf.patch10
-rw-r--r--net-analyzer/ndoutils/files/ndoutils-2.0.0-asprintf.patch10
-rw-r--r--net-analyzer/ndoutils/files/ndoutils-2.0.0-sleep.patch10
-rw-r--r--net-analyzer/ndoutils/metadata.xml8
-rw-r--r--net-analyzer/ndoutils/ndoutils-1.5.2.ebuild64
-rw-r--r--net-analyzer/ndoutils/ndoutils-2.0.0.ebuild68
8 files changed, 197 insertions, 0 deletions
diff --git a/net-analyzer/ndoutils/Manifest b/net-analyzer/ndoutils/Manifest
new file mode 100644
index 000000000000..272f39bfae5b
--- /dev/null
+++ b/net-analyzer/ndoutils/Manifest
@@ -0,0 +1,2 @@
+DIST ndoutils-1.5.2.tar.gz 2142271 SHA256 fe80b5d23291b780741f223efe807f690e3414e706844e993bc40913bd09c7f7 SHA512 3aac9917b8a557f8a7a3cd3cc5460e27617cdf0aab6f007da96a0ffecc4b3bbf3b2c08ef57d7daab8f4b6c5ff172b7d11ef74c84b3e84ae67460731209582ca1 WHIRLPOOL b49a4cc2c78010534cc2219b7cec14866a9bf72595e407eecf8b49487e1f4046132dc309d8a706b0eb688509d6a2983edb68a777da7e1ae019344a8dfac4feb1
+DIST ndoutils-2.0.0.tar.gz 2207263 SHA256 b95047c812fb61465e66a9e1a6d4a42bf00620f334f08a6faf5afe20bdd43ba1 SHA512 c899c9f9d0a14995ae7e3fc9f8566891acef9186cc53f05e4f509e9dd01a19a17d32c746a4a1c125342ebffad65946c7a3ea11da68ce0ff240bd37e85334545c WHIRLPOOL d3e41eb5e2a3ea9a5ca0d24fc8319beaa914d2bcb16c187ab6c5f5a3f133c27756ecdc2b6302a75c015294a1b2c3cc48d3c87a540ae1b9b07a21eb427b45d181
diff --git a/net-analyzer/ndoutils/files/ndo2db.init-nagios3 b/net-analyzer/ndoutils/files/ndo2db.init-nagios3
new file mode 100755
index 000000000000..60913254ab1d
--- /dev/null
+++ b/net-analyzer/ndoutils/files/ndo2db.init-nagios3
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depends() {
+ before nagios
+ need mysql
+}
+
+start() {
+ ebegin "Starting ndo2db"
+ if [ -S /var/nagios/ndo.sock ] ; then
+ rm -f /var/nagios/ndo.sock
+ fi
+ start-stop-daemon --start --quiet --exec /usr/bin/ndo2db \
+ -- -c /etc/nagios/ndo2db.cfg
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ndo2db"
+ start-stop-daemon --stop --quiet --exec /usr/bin/ndo2db
+ eend $?
+}
diff --git a/net-analyzer/ndoutils/files/ndoutils-1.4_beta9-asprintf.patch b/net-analyzer/ndoutils/files/ndoutils-1.4_beta9-asprintf.patch
new file mode 100644
index 000000000000..146132c21de3
--- /dev/null
+++ b/net-analyzer/ndoutils/files/ndoutils-1.4_beta9-asprintf.patch
@@ -0,0 +1,10 @@
+--- a/include/config.h.in
++++ b/include/config.h.in
+@@ -9,6 +9,7 @@
+ #ifndef _CONFIG_H
+ #define _CONFIG_H
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+
diff --git a/net-analyzer/ndoutils/files/ndoutils-2.0.0-asprintf.patch b/net-analyzer/ndoutils/files/ndoutils-2.0.0-asprintf.patch
new file mode 100644
index 000000000000..146132c21de3
--- /dev/null
+++ b/net-analyzer/ndoutils/files/ndoutils-2.0.0-asprintf.patch
@@ -0,0 +1,10 @@
+--- a/include/config.h.in
++++ b/include/config.h.in
+@@ -9,6 +9,7 @@
+ #ifndef _CONFIG_H
+ #define _CONFIG_H
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+
diff --git a/net-analyzer/ndoutils/files/ndoutils-2.0.0-sleep.patch b/net-analyzer/ndoutils/files/ndoutils-2.0.0-sleep.patch
new file mode 100644
index 000000000000..61694baee9e3
--- /dev/null
+++ b/net-analyzer/ndoutils/files/ndoutils-2.0.0-sleep.patch
@@ -0,0 +1,10 @@
+--- a/src/queue.c
++++ b/src/queue.c
+@@ -8,6 +8,7 @@
+ #include "../include/queue.h"
+ #include <errno.h>
+ #include <time.h>
++#include <unistd.h> /* sleep() */
+
+ #define RETRY_LOG_INTERVAL 600 /* Seconds */
+ #define MAX_RETRIES 20 /* Max number of times to retry sending message */
diff --git a/net-analyzer/ndoutils/metadata.xml b/net-analyzer/ndoutils/metadata.xml
new file mode 100644
index 000000000000..c8b1c872b132
--- /dev/null
+++ b/net-analyzer/ndoutils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">nagios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/ndoutils/ndoutils-1.5.2.ebuild b/net-analyzer/ndoutils/ndoutils-1.5.2.ebuild
new file mode 100644
index 000000000000..dcb3a2470102
--- /dev/null
+++ b/net-analyzer/ndoutils/ndoutils-1.5.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils user
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org"
+SRC_URI="mirror://sourceforge/nagios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+DEPEND="
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ virtual/mysql
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-analyzer/nagios-core-3.0
+"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.4_beta9-asprintf.patch \
+ "${FILESDIR}"/${PN}-2.0.0-sleep.patch
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/nagios \
+ --enable-mysql
+}
+
+DOCS=(
+ 'docs/NDOUTILS DB Model.pdf'
+ 'docs/NDOUtils Documentation.pdf'
+ Changelog
+ README
+ REQUIREMENTS
+ TODO
+ UPGRADING
+)
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-config
+
+ newinitd "${FILESDIR}"/ndo2db.init-nagios3 ndo2db
+}
+
+pkg_postinst() {
+ elog "To include NDO in your Nagios setup you'll need to activate the NDO broker module"
+ elog "in /etc/nagios/nagios.cfg:"
+ elog "\tbroker_module=/usr/bin/ndomod-3x.o config_file=/etc/nagios/ndomod.cfg"
+}
diff --git a/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild b/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild
new file mode 100644
index 000000000000..a7285fe8e9fc
--- /dev/null
+++ b/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils user
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+DEPEND="
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ virtual/mysql
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-analyzer/nagios-core-3.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-asprintf.patch \
+ "${FILESDIR}"/${P}-sleep.patch
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/nagios \
+ --enable-mysql
+}
+
+DOCS=(
+ 'docs/NDOUTILS DB Model.pdf'
+ 'docs/NDOUtils Documentation.pdf'
+ Changelog
+ README
+ REQUIREMENTS
+ TODO
+ UPGRADING
+)
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-config
+
+ newinitd "${FILESDIR}"/ndo2db.init-nagios3 ndo2db
+}
+
+pkg_postinst() {
+ elog "To include NDO in your Nagios setup you'll need to activate the NDO broker module"
+ elog "in /etc/nagios/nagios.cfg:"
+ elog "\tbroker_module=/usr/bin/ndomod-3x.o config_file=/etc/nagios/ndomod.cfg"
+}