summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nepenthes/nepenthes-0.2.2.ebuild')
-rw-r--r--net-analyzer/nepenthes/nepenthes-0.2.2.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
new file mode 100644
index 000000000000..500ee35a2b9f
--- /dev/null
+++ b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit autotools eutils user
+
+DESCRIPTION="Nepenthes is a low interaction honeypot that captures worms by emulating known vulnerabilities"
+HOMEPAGE="http://nepenthes.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}-gcc44.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+# selinux
+
+DEPEND="net-misc/curl
+ sys-apps/file
+ dev-libs/libpcre
+ net-libs/adns"
+
+RDEPEND=""
+#RDEPEND=" selinux? ( sec-policy/selinux-nepenthes )"
+
+pkg_setup() {
+ enewgroup nepenthes
+ enewuser nepenthes -1 -1 /dev/null nepenthes
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${WORKDIR}"/${P}-gcc44.patch
+ sed -i modules/shellcode-signatures/shellcode-signatures.cpp \
+ -e 's|var/cache|/var/lib/cache|' || die
+ sed -i configure.ac \
+ -e 's|-R/usr/local/lib||g' || die
+ find . -name Makefile.am -exec sed 's: -Werror::' -i '{}' \;
+
+ # fix for bug #426482
+ has_version ">=net-misc/curl-7.22.0" && find . -type f -exec sed '/#include <curl\/types.h>/d' -i '{}' \;
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir=/etc \
+ --localstatedir=/var/lib/nepenthes \
+ --enable-capabilities
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ for i in "${D}"/etc/nepenthes/*; do
+ sed -i \
+ -e 's|"var/binaries|"/var/lib/nepenthes/binaries|' \
+ -e 's|"var/hexdumps|"/var/lib/nepenthes/hexdumps|' \
+ -e 's|"var/cache/nepenthes|"/var/lib/nepenthes/cache|' \
+ -e 's|"var/log|"/var/log/nepenthes|' \
+ -e 's|"lib/nepenthes|"/usr/lib/nepenthes|' \
+ -e 's|"etc|"/etc|' $i
+ done
+
+ dodoc doc/README.VFS AUTHORS
+ dosbin nepenthes-core/src/nepenthes || die "dosbin failed"
+ rm "${D}"/usr/bin/nepenthes
+ rm "${D}"/usr/share/doc/README.VFS
+ rm "${D}"/usr/share/doc/logo-shaded.svg
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ diropts -m 755 -o nepenthes -g nepenthes
+ keepdir /var/log/nepenthes
+ keepdir /var/lib/nepenthes
+ keepdir /var/lib/nepenthes/binaries
+ keepdir /var/lib/nepenthes/hexdumps
+ keepdir /var/lib/nepenthes/cache
+ keepdir /var/lib/nepenthes/cache/geolocation
+}