summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nessus-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nessus-core')
-rw-r--r--net-analyzer/nessus-core/Manifest1
-rw-r--r--net-analyzer/nessus-core/files/2.2.9-crash.patch15
-rw-r--r--net-analyzer/nessus-core/files/2.2.9-gentoo.patch58
-rw-r--r--net-analyzer/nessus-core/files/nessus-core-2.2.9-open.patch11
-rw-r--r--net-analyzer/nessus-core/files/nessusd-r726
-rw-r--r--net-analyzer/nessus-core/metadata.xml6
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.2.9-r1.ebuild66
7 files changed, 183 insertions, 0 deletions
diff --git a/net-analyzer/nessus-core/Manifest b/net-analyzer/nessus-core/Manifest
new file mode 100644
index 000000000000..be37616e0955
--- /dev/null
+++ b/net-analyzer/nessus-core/Manifest
@@ -0,0 +1 @@
+DIST nessus-core-2.2.9.tar.gz 674390 SHA256 b725ace4ef619bc19b372eac9a60db7b083a3e155e11c65443618e52b56c847e
diff --git a/net-analyzer/nessus-core/files/2.2.9-crash.patch b/net-analyzer/nessus-core/files/2.2.9-crash.patch
new file mode 100644
index 000000000000..d95c28404de2
--- /dev/null
+++ b/net-analyzer/nessus-core/files/2.2.9-crash.patch
@@ -0,0 +1,15 @@
+--- nessus-core/nessus/auth.c 2007-08-31 23:12:36.000000000 +0200
++++ nessus-core/nessus/auth.c 2007-08-31 23:12:52.000000000 +0200
+@@ -92,11 +92,11 @@
+ char * buffer = emalloc(s);
+ int len, n = 0;
+ signal(SIGPIPE, sighand_pipe);
+- va_start(param, data);
+
+
+ for(;;)
+ {
++ va_start(param, data);
+ r = vsnprintf(buffer, s - 1, data, param);
+ if(r >= 0 && r < s)break;
+ s = r > s ? r + 2 : s * 2;
diff --git a/net-analyzer/nessus-core/files/2.2.9-gentoo.patch b/net-analyzer/nessus-core/files/2.2.9-gentoo.patch
new file mode 100644
index 000000000000..c97f6979340d
--- /dev/null
+++ b/net-analyzer/nessus-core/files/2.2.9-gentoo.patch
@@ -0,0 +1,58 @@
+ Makefile | 10 +++++-----
+ nessus-fetch/Makefile | 2 +-
+ ssl/Makefile | 2 +-
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b1485b3..382900a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -86,17 +86,17 @@ client-install : client
+ $(INSTALL) -m $(CLIENTMODE) ${make_bindir}/nessus $(DESTDIR)${bindir}
+
+ client :
+- cd nessus && $(MAKE)
++ $(MAKE) -C nessus
+
+-server :
+- cd nessusd && $(MAKE)
++server : client
++ $(MAKE) -C nessusd
+
+ sslstuff :
+- cd ssl && $(MAKE)
++ $(MAKE) -C ssl
+
+
+ fetchtool:
+- cd nessus-fetch && $(MAKE)
++ $(MAKE) -C nessus-fetch
+
+
+ doc : $(MAN_NESSUS_1) $(MAN_NESSUSD_8)
+diff --git a/nessus-fetch/Makefile b/nessus-fetch/Makefile
+index 63439bc..89fd8c9 100644
+--- a/nessus-fetch/Makefile
++++ b/nessus-fetch/Makefile
+@@ -5,7 +5,7 @@ include ../nessus.tmpl
+ all: nessus-fetch
+
+ nessus-fetch: nessus-fetch.o
+- $(CC) nessus-fetch.o -o nessus-fetch $(LIBS)
++ $(CC) $(LDFLAGS) nessus-fetch.o -o nessus-fetch $(LIBS)
+
+ nessus-fetch.o: nessus-fetch.c
+ $(CC) $(NESSUS_CFLAGS) ${include} $(DEFS) $(NESSUS_DEFS) -c nessus-fetch.c
+diff --git a/ssl/Makefile b/ssl/Makefile
+index 738a692..5e51426 100644
+--- a/ssl/Makefile
++++ b/ssl/Makefile
+@@ -6,7 +6,7 @@ OBJS = nessus-mkrand.o
+ all : nessus-mkrand
+
+ nessus-mkrand: $(OBJS)
+- $(CC) $(OBJS) -o nessus-mkrand -lm
++ $(CC) $(LDFLAGS) $(OBJS) -o nessus-mkrand -lm
+
+ nessus-mkrand.o: nessus-mkrand.c
+ $(CC) $(CFLAGS) -c nessus-mkrand.c
diff --git a/net-analyzer/nessus-core/files/nessus-core-2.2.9-open.patch b/net-analyzer/nessus-core/files/nessus-core-2.2.9-open.patch
new file mode 100644
index 000000000000..fe60ede62b29
--- /dev/null
+++ b/net-analyzer/nessus-core/files/nessus-core-2.2.9-open.patch
@@ -0,0 +1,11 @@
+--- nessus-core/nessusd/detached.c.orig
++++ nessus-core/nessusd/detached.c
+@@ -408,7 +408,7 @@
+ char * target;
+ {
+ char * fname = detached_fname(globals);
+- int f = open(fname, O_CREAT|O_WRONLY|O_TRUNC);
++ int f = open(fname, O_CREAT|O_WRONLY|O_TRUNC, 0600);
+ if(f >= 0)
+ {
+ write(f, target, strlen(target));
diff --git a/net-analyzer/nessus-core/files/nessusd-r7 b/net-analyzer/nessus-core/files/nessusd-r7
new file mode 100644
index 000000000000..5707584ce427
--- /dev/null
+++ b/net-analyzer/nessus-core/files/nessusd-r7
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting nessusd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/nessusd -- -D
+ eend $?
+}
+
+stop() {
+ ebegin "Stop nessusd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/nessusd
+ einfo "Waiting for the environment to be sane"
+ while [ -n "$RUNNING" ] ; do
+ sleep 1
+ RUNNING=$(ps aux | grep -m 1 nessusd: | grep -v grep)
+ done
+ sleep 3
+ eend $?
+}
diff --git a/net-analyzer/nessus-core/metadata.xml b/net-analyzer/nessus-core/metadata.xml
new file mode 100644
index 000000000000..b4c5e4abe562
--- /dev/null
+++ b/net-analyzer/nessus-core/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>A remote security scanner for Linux (nessus-core)</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/nessus-core/nessus-core-2.2.9-r1.ebuild b/net-analyzer/nessus-core/nessus-core-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..c9d246400281
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-2.2.9-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs eutils autotools
+
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug gtk prelude tcpd"
+
+RDEPEND="
+ ~net-analyzer/nessus-libraries-${PV}
+ ~net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
+ gtk? ( x11-libs/gtk+:2 )
+ prelude? ( dev-libs/libprelude )
+ !net-analyzer/nessus-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}
+
+DOCS="README* UPGRADE_README CHANGES doc/*.txt doc/ntp/*"
+
+src_prepare() {
+ tc-export CC
+ epatch \
+ "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${PV}-crash.patch \
+ "${FILESDIR}"/${P}-open.patch
+
+ sed -i -e "/^LDFLAGS/s:$:${LDFLAGS}:g" nessus.tmpl.in || die
+ sed -i -e 's:CFLAGS="-g"; ::' configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd tcpwrappers) \
+ $(use_enable debug) \
+ $(use_enable gtk)
+}
+
+src_compile() {
+ emake -C nessus cflags
+ emake -C nessusd cflags
+ default
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/nessusd-r7 nessusd
+ keepdir /var/lib/nessus/logs
+ keepdir /var/lib/nessus/users
+ # newer version is provided by nessus-libraries
+ # should be fixed upstream in version 2.2.6
+ rm "${ED}"/usr/include/nessus/includes.h
+}