summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-15 15:18:04 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-15 15:18:30 +0200
commit41ce6d213a8daee9d1d607a836bec31a4b975085 (patch)
tree9abf6b55ac98b24c0bd8ec55bcb2c038d5b206ce /net-analyzer/net-snmp/net-snmp-99999999.ebuild
parentnet-misc/remmina: bump to 1.4.8 (diff)
downloadgentoo-41ce6d213a8daee9d1d607a836bec31a4b975085.tar.gz
gentoo-41ce6d213a8daee9d1d607a836bec31a4b975085.tar.bz2
gentoo-41ce6d213a8daee9d1d607a836bec31a4b975085.zip
net-analyzer/net-snmp: Version 5.9
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/net-snmp/net-snmp-99999999.ebuild')
-rw-r--r--net-analyzer/net-snmp/net-snmp-99999999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-99999999.ebuild b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
index d75684cc5afe..b3478934c9a1 100644
--- a/net-analyzer/net-snmp/net-snmp-99999999.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
@@ -2,13 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_SINGLE_IMPL=yesplz
DISTUTILS_OPTIONAL=yesplz
-WANT_AUTOMAKE=none
-PATCHSET=3
+DISTUTILS_SINGLE_IMPL=yesplz
GENTOO_DEPEND_ON_PERL=no
-
+PATCHSET=3
+PYTHON_COMPAT=( python3_{6,7,8} )
+WANT_AUTOMAKE=none
inherit autotools distutils-r1 git-r3 perl-module systemd
DESCRIPTION="Software for generating and retrieving SNMP data"
@@ -69,8 +68,6 @@ RDEPEND="
)
selinux? ( sec-policy/selinux-snmp )
"
-S=${WORKDIR}/${P/_/.}
-S=${WORKDIR}/${P/_p*/}
RESTRICT=test
PATCHES=(
"${FILESDIR}"/${PN}-5.7.3-include-limits.patch
@@ -79,6 +76,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.8.1-pkg-config.patch
"${FILESDIR}"/${PN}-5.8.1-net-snmp-config-libdir.patch
"${FILESDIR}"/${PN}-5.8.1-mysqlclient.patch
+ "${FILESDIR}"/${PN}-5.9-MakeMaker.patch
"${FILESDIR}"/${PN}-99999999-tinfo.patch
)
@@ -132,7 +130,8 @@ src_configure() {
$(use_with ssl openssl) \
$(use_with tcpd libwrap) \
$(use_with zlib) \
- --enable-shared --disable-static \
+ --disable-static \
+ --enable-shared \
--with-default-snmp-version="3" \
--with-install-prefix="${D}" \
--with-ldflags="${LDFLAGS}" \
@@ -144,8 +143,9 @@ src_configure() {
}
src_compile() {
- for target in snmplib agent sedscript all; do
- emake OTHERLDFLAGS="${LDFLAGS}" ${target}
+ local subdir
+ for subdir in snmplib agent/mibgroup agent apps .; do
+ emake OTHERLDFLAGS="${LDFLAGS}" -C ${subdir} all
done
use doc && emake docsdox