summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-03-20 15:53:22 -0400
committerDavid Seifert <soap@gentoo.org>2017-03-24 17:56:04 +0100
commit3c23603512cc46d0e83821776b1a78982e1094e0 (patch)
treebd45bbebad8c1e724b16890f4740e8abeca1f092 /net-analyzer/netdata/netdata-9999.ebuild
parentmedia-tv/kodi: Remove old version 17.1_rc1 (diff)
downloadgentoo-3c23603512cc46d0e83821776b1a78982e1094e0.tar.gz
gentoo-3c23603512cc46d0e83821776b1a78982e1094e0.tar.bz2
gentoo-3c23603512cc46d0e83821776b1a78982e1094e0.zip
net-analyzer/netdata: version bump 1.6.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4264
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild44
1 files changed, 23 insertions, 21 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index f23d6499dcd1..63f879951fa5 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -2,15 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit autotools fcaps linux-info python-r1 systemd user
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="git://github.com/firehol/${PN}.git"
inherit git-r3
- SRC_URI=""
- KEYWORDS=""
else
SRC_URI="https://github.com/firehol/netdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -21,39 +19,42 @@ HOMEPAGE="https://github.com/firehol/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="+compression cpu_flags_x86_sse2 mysql nfacct nodejs postgres +python"
+IUSE="caps +compression cpu_flags_x86_sse2 ipmi mysql nfacct nodejs postgres +python"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )"
# most unconditional dependencies are for plugins.d/charts.d.plugin:
RDEPEND="
>=app-shells/bash-4:0
+ || (
+ net-analyzer/netcat6
+ net-analyzer/netcat
+ )
+ net-analyzer/tcpdump
+ net-analyzer/traceroute
net-misc/curl
net-misc/wget
+ sys-apps/util-linux
virtual/awk
- net-libs/libmnl
- || ( net-analyzer/netcat6 net-analyzer/netcat )
- net-analyzer/tcpdump
- net-analyzer/traceroute
+ caps? ( sys-libs/libcap )
compression? ( sys-libs/zlib )
+ ipmi? ( sys-libs/freeipmi )
+ nfacct? (
+ net-firewall/nfacct
+ net-libs/libmnl
+ )
+ nodejs? ( net-libs/nodejs )
python? (
${PYTHON_DEPS}
dev-python/pyyaml[${PYTHON_USEDEP}]
mysql? (
- || ( dev-python/mysqlclient[${PYTHON_USEDEP}] dev-python/mysql-python[${PYTHON_USEDEP}] )
- )
- postgres? (
- dev-python/psycopg:2[${PYTHON_USEDEP}]
+ || (
+ dev-python/mysqlclient[${PYTHON_USEDEP}]
+ dev-python/mysql-python[${PYTHON_USEDEP}]
+ )
)
- )
- nfacct? (
- net-firewall/nfacct
- net-libs/libmnl
- )
- nodejs? (
- net-libs/nodejs
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
)"
-
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -81,6 +82,7 @@ src_configure() {
--localstatedir="${EPREFIX}"/var \
--with-user=${NETDATA_USER} \
$(use_enable nfacct plugin-nfacct) \
+ $(use_enable ipmi plugin-freeipmi) \
$(use_enable cpu_flags_x86_sse2 x86-sse) \
$(use_with compression zlib)
}