summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-04-17 09:04:13 -0400
committerCraig Andrews <candrews@gentoo.org>2020-04-17 09:05:33 -0400
commit30b1724bc0da1f4896c667c5e22ea3dd135d6762 (patch)
treef986cc27c65124b15962125c1183514e74fa67e4 /net-analyzer/netdata
parentnet-analyzer/netdata: Add Python 3.8 support (diff)
downloadgentoo-30b1724bc0da1f4896c667c5e22ea3dd135d6762.tar.gz
gentoo-30b1724bc0da1f4896c667c5e22ea3dd135d6762.tar.bz2
gentoo-30b1724bc0da1f4896c667c5e22ea3dd135d6762.zip
net-analyzer/netdata: Cleanup old versions
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-analyzer/netdata')
-rw-r--r--net-analyzer/netdata/Manifest3
-rw-r--r--net-analyzer/netdata/netdata-1.19.0-r2.ebuild146
-rw-r--r--net-analyzer/netdata/netdata-1.20.0-r1.ebuild139
-rw-r--r--net-analyzer/netdata/netdata-1.20.0.ebuild139
-rw-r--r--net-analyzer/netdata/netdata-1.21.0.ebuild139
5 files changed, 0 insertions, 566 deletions
diff --git a/net-analyzer/netdata/Manifest b/net-analyzer/netdata/Manifest
index 92f16307b9d3..04dde0573f14 100644
--- a/net-analyzer/netdata/Manifest
+++ b/net-analyzer/netdata/Manifest
@@ -1,4 +1 @@
-DIST netdata-1.19.0.tar.gz 3443251 BLAKE2B 8e18a661367850e712a75c1c11b661a977bf77b48369e0e36763a74f96b3726c523093a82eb6f94257c02e754d900cb675d501fda824ceb94eef31dfa30e5712 SHA512 026ae159d8ed52a30e406c110c2732e54e50f070865ba3e430df73e4df40387105053e750ca6029cfbc7f40a2c05b7fb6ba4e3e4a7070822c7eec4c1a4712aea
-DIST netdata-1.20.0.tar.gz 3598521 BLAKE2B 3837ef2beb1b275af89e5927362ab0b83f13cc1227d156f742f4c29ecc9f79de212987c13d6707ac785abac7ae5ce979333a50d5c521b0f019f8cbdf88f831a1 SHA512 ada398cdccf1b1b4dbac5b24d4539f86aafb964458aa4f3bdfac336362504aab6d74b7f2f12bad18b62a44bb62d1a2a8ddd0c2ed80a7c16bc388854d4210bcb6
-DIST netdata-1.21.0.tar.gz 3747997 BLAKE2B 1c7d0b26f1ea1203fbab9e7d1bbf6de3c7dc18e73cf4f700fd5d6d658714b4b468568d8699695b7b7bf94a29ec3cacc634cbe2f99d6741c6ebf28faa1f59415f SHA512 65d3bd7dc3cace861184f8293f24e9d4ba20389c6d5e4176631c04ecf4a5e92c328fb6673fcefaecf2d2cc1296bfc0aa35d81b3284c7d3fb6729bb101fef8475
DIST netdata-1.21.1.tar.gz 3748090 BLAKE2B 5cc8dd47b768838eecc7c8af35a82548dc5bb16acb0a88c17ee1254f86ca9b63a5108bce9205c000283b817478749d963b69c65e3bdc8e2fadecc9a1826a7f2e SHA512 66d2e0cb977275250fd7b51e5156957a4506ddba586de5fe796459ea241cbbed7013fd4cf9d7acf6666407352fb34e3b962a2d01565a9cb982c89c76b7cd79b9
diff --git a/net-analyzer/netdata/netdata-1.19.0-r2.ebuild b/net-analyzer/netdata/netdata-1.19.0-r2.ebuild
deleted file mode 100644
index 41c6f9ef672d..000000000000
--- a/net-analyzer/netdata/netdata-1.19.0-r2.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit autotools fcaps linux-info python-r1 systemd
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Linux real time system monitoring, done right!"
-HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
-
-LICENSE="GPL-3+ MIT BSD"
-SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
-REQUIRED_USE="
- mysql? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- tor? ( python )"
-
-# most unconditional dependencies are for plugins.d/charts.d.plugin:
-RDEPEND="
- acct-group/netdata
- acct-user/netdata
- app-misc/jq
- >=app-shells/bash-4:0
- || (
- net-analyzer/openbsd-netcat
- net-analyzer/netcat
- )
- net-misc/curl
- net-misc/wget
- sys-apps/util-linux
- virtual/awk
- caps? ( sys-libs/libcap )
- cups? ( net-print/cups )
- dbengine? (
- dev-libs/libuv
- app-arch/lz4
- dev-libs/judy
- dev-libs/openssl:=
- )
- compression? ( sys-libs/zlib )
- ipmi? ( sys-libs/freeipmi )
- jsonc? ( dev-libs/json-c )
- kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
- mongodb? ( dev-libs/mongo-c-driver )
- nfacct? (
- net-firewall/nfacct
- net-libs/libmnl
- )
- nodejs? ( net-libs/nodejs )
- prometheus? (
- dev-libs/protobuf:=
- app-arch/snappy
- )
- python? (
- ${PYTHON_DEPS}
- dev-python/pyyaml[${PYTHON_USEDEP}]
- mysql? (
- || (
- dev-python/mysqlclient[${PYTHON_USEDEP}]
- dev-python/mysql-python[${PYTHON_USEDEP}]
- )
- )
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- tor? ( net-libs/stem[${PYTHON_USEDEP}] )
- )
- xen? (
- app-emulation/xen-tools
- dev-libs/yajl
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-FILECAPS=(
- 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
-)
-
-PATCHES=(
- "${FILESDIR}/${P}-prometheus-spelling.patch"
- "${FILESDIR}/${P}-fno-common.patch"
-)
-
-pkg_setup() {
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --localstatedir="${EPREFIX}"/var \
- --with-user=netdata \
- $(use_enable jsonc) \
- $(use_enable cups plugin-cups) \
- $(use_enable dbengine) \
- $(use_enable nfacct plugin-nfacct) \
- $(use_enable ipmi plugin-freeipmi) \
- $(use_enable kinesis backend-kinesis) \
- $(use_enable mongodb backend-mongodb) \
- $(use_enable prometheus backend-prometheus-remote-write) \
- $(use_enable xen plugin-xenstat) \
- $(use_enable cpu_flags_x86_sse2 x86-sse) \
- $(use_with compression zlib)
-}
-
-src_install() {
- default
-
- rm -rf "${D}/var/cache" || die
-
- # Remove unneeded .keep files
- find "${ED}" -name ".keep" -delete || die
-
- fowners -Rc netdata:netdata /var/log/netdata
- keepdir /var/log/netdata
- fowners -Rc netdata:netdata /var/lib/netdata
- keepdir /var/lib/netdata
- keepdir /var/lib/netdata/registry
-
- fowners -Rc root:netdata /usr/share/${PN}
-
- newinitd system/netdata-openrc ${PN}
- systemd_dounit system/netdata.service
- insinto /etc/netdata
- doins system/netdata.conf
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if use xen ; then
- fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
- fi
-}
diff --git a/net-analyzer/netdata/netdata-1.20.0-r1.ebuild b/net-analyzer/netdata/netdata-1.20.0-r1.ebuild
deleted file mode 100644
index 05058d2b9921..000000000000
--- a/net-analyzer/netdata/netdata-1.20.0-r1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit autotools fcaps linux-info python-single-r1 systemd
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Linux real time system monitoring, done right!"
-HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
-
-LICENSE="GPL-3+ MIT BSD"
-SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
-REQUIRED_USE="
- mysql? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- tor? ( python )"
-
-# most unconditional dependencies are for plugins.d/charts.d.plugin:
-RDEPEND="
- acct-group/netdata
- acct-user/netdata
- app-misc/jq
- >=app-shells/bash-4:0
- || (
- net-analyzer/openbsd-netcat
- net-analyzer/netcat
- )
- net-misc/curl
- net-misc/wget
- sys-apps/util-linux
- virtual/awk
- caps? ( sys-libs/libcap )
- cups? ( net-print/cups )
- dbengine? (
- dev-libs/libuv
- app-arch/lz4
- dev-libs/judy
- dev-libs/openssl:=
- )
- compression? ( sys-libs/zlib )
- ipmi? ( sys-libs/freeipmi )
- jsonc? ( dev-libs/json-c )
- kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
- mongodb? ( dev-libs/mongo-c-driver )
- nfacct? (
- net-firewall/nfacct
- net-libs/libmnl
- )
- nodejs? ( net-libs/nodejs )
- prometheus? (
- dev-libs/protobuf:=
- app-arch/snappy
- )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
- mysql? (
- || (
- $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
- )
- )
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
- tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
- )
- xen? (
- app-emulation/xen-tools
- dev-libs/yajl
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-FILECAPS=(
- 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --localstatedir="${EPREFIX}"/var \
- --with-user=netdata \
- $(use_enable jsonc) \
- $(use_enable cups plugin-cups) \
- $(use_enable dbengine) \
- $(use_enable nfacct plugin-nfacct) \
- $(use_enable ipmi plugin-freeipmi) \
- $(use_enable kinesis backend-kinesis) \
- $(use_enable mongodb backend-mongodb) \
- $(use_enable prometheus backend-prometheus-remote-write) \
- $(use_enable xen plugin-xenstat) \
- $(use_enable cpu_flags_x86_sse2 x86-sse) \
- $(use_with compression zlib)
-}
-
-src_install() {
- default
-
- rm -rf "${D}/var/cache" || die
-
- keepdir /var/log/netdata
- fowners -Rc netdata:netdata /var/log/netdata
- keepdir /var/lib/netdata
- keepdir /var/lib/netdata/registry
- fowners -Rc netdata:netdata /var/lib/netdata
-
- fowners -Rc root:netdata /usr/share/${PN}
-
- newinitd system/netdata-openrc ${PN}
- systemd_dounit system/netdata.service
- insinto /etc/netdata
- doins system/netdata.conf
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if use xen ; then
- fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
- fi
-}
diff --git a/net-analyzer/netdata/netdata-1.20.0.ebuild b/net-analyzer/netdata/netdata-1.20.0.ebuild
deleted file mode 100644
index 38d285c386ee..000000000000
--- a/net-analyzer/netdata/netdata-1.20.0.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit autotools fcaps linux-info python-single-r1 systemd
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Linux real time system monitoring, done right!"
-HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
-
-LICENSE="GPL-3+ MIT BSD"
-SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
-REQUIRED_USE="
- mysql? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- tor? ( python )"
-
-# most unconditional dependencies are for plugins.d/charts.d.plugin:
-RDEPEND="
- acct-group/netdata
- acct-user/netdata
- app-misc/jq
- >=app-shells/bash-4:0
- || (
- net-analyzer/openbsd-netcat
- net-analyzer/netcat
- )
- net-misc/curl
- net-misc/wget
- sys-apps/util-linux
- virtual/awk
- caps? ( sys-libs/libcap )
- cups? ( net-print/cups )
- dbengine? (
- dev-libs/libuv
- app-arch/lz4
- dev-libs/judy
- dev-libs/openssl:=
- )
- compression? ( sys-libs/zlib )
- ipmi? ( sys-libs/freeipmi )
- jsonc? ( dev-libs/json-c )
- kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
- mongodb? ( dev-libs/mongo-c-driver )
- nfacct? (
- net-firewall/nfacct
- net-libs/libmnl
- )
- nodejs? ( net-libs/nodejs )
- prometheus? (
- dev-libs/protobuf:=
- app-arch/snappy
- )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
- mysql? (
- || (
- $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
- )
- )
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
- tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
- )
- xen? (
- app-emulation/xen-tools
- dev-libs/yajl
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-FILECAPS=(
- 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --localstatedir="${EPREFIX}"/var \
- --with-user=netdata \
- $(use_enable jsonc) \
- $(use_enable cups plugin-cups) \
- $(use_enable dbengine) \
- $(use_enable nfacct plugin-nfacct) \
- $(use_enable ipmi plugin-freeipmi) \
- $(use_enable kinesis backend-kinesis) \
- $(use_enable mongodb backend-mongodb) \
- $(use_enable prometheus backend-prometheus-remote-write) \
- $(use_enable xen plugin-xenstat) \
- $(use_enable cpu_flags_x86_sse2 x86-sse) \
- $(use_with compression zlib)
-}
-
-src_install() {
- default
-
- rm -rf "${D}/var/cache" || die
-
- keepdir /var/log/netdata
- fowners -Rc netdata:netdata /var/log/netdata
- keepdir /var/lib/netdata
- fowners -Rc netdata:netdata /var/lib/netdata
- keepdir /var/lib/netdata/registry
-
- fowners -Rc root:netdata /usr/share/${PN}
-
- newinitd system/netdata-openrc ${PN}
- systemd_dounit system/netdata.service
- insinto /etc/netdata
- doins system/netdata.conf
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if use xen ; then
- fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
- fi
-}
diff --git a/net-analyzer/netdata/netdata-1.21.0.ebuild b/net-analyzer/netdata/netdata-1.21.0.ebuild
deleted file mode 100644
index 05058d2b9921..000000000000
--- a/net-analyzer/netdata/netdata-1.21.0.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit autotools fcaps linux-info python-single-r1 systemd
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Linux real time system monitoring, done right!"
-HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
-
-LICENSE="GPL-3+ MIT BSD"
-SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
-REQUIRED_USE="
- mysql? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- tor? ( python )"
-
-# most unconditional dependencies are for plugins.d/charts.d.plugin:
-RDEPEND="
- acct-group/netdata
- acct-user/netdata
- app-misc/jq
- >=app-shells/bash-4:0
- || (
- net-analyzer/openbsd-netcat
- net-analyzer/netcat
- )
- net-misc/curl
- net-misc/wget
- sys-apps/util-linux
- virtual/awk
- caps? ( sys-libs/libcap )
- cups? ( net-print/cups )
- dbengine? (
- dev-libs/libuv
- app-arch/lz4
- dev-libs/judy
- dev-libs/openssl:=
- )
- compression? ( sys-libs/zlib )
- ipmi? ( sys-libs/freeipmi )
- jsonc? ( dev-libs/json-c )
- kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
- mongodb? ( dev-libs/mongo-c-driver )
- nfacct? (
- net-firewall/nfacct
- net-libs/libmnl
- )
- nodejs? ( net-libs/nodejs )
- prometheus? (
- dev-libs/protobuf:=
- app-arch/snappy
- )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
- mysql? (
- || (
- $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
- $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
- )
- )
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
- tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
- )
- xen? (
- app-emulation/xen-tools
- dev-libs/yajl
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-FILECAPS=(
- 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --localstatedir="${EPREFIX}"/var \
- --with-user=netdata \
- $(use_enable jsonc) \
- $(use_enable cups plugin-cups) \
- $(use_enable dbengine) \
- $(use_enable nfacct plugin-nfacct) \
- $(use_enable ipmi plugin-freeipmi) \
- $(use_enable kinesis backend-kinesis) \
- $(use_enable mongodb backend-mongodb) \
- $(use_enable prometheus backend-prometheus-remote-write) \
- $(use_enable xen plugin-xenstat) \
- $(use_enable cpu_flags_x86_sse2 x86-sse) \
- $(use_with compression zlib)
-}
-
-src_install() {
- default
-
- rm -rf "${D}/var/cache" || die
-
- keepdir /var/log/netdata
- fowners -Rc netdata:netdata /var/log/netdata
- keepdir /var/lib/netdata
- keepdir /var/lib/netdata/registry
- fowners -Rc netdata:netdata /var/lib/netdata
-
- fowners -Rc root:netdata /usr/share/${PN}
-
- newinitd system/netdata-openrc ${PN}
- systemd_dounit system/netdata.service
- insinto /etc/netdata
- doins system/netdata.conf
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if use xen ; then
- fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
- fi
-}