summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-28 15:19:46 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-28 16:38:24 +0100
commit738f0a65389a1d424a80f6e622d84da62c68ab46 (patch)
tree8ef8d00e42ee525c8fcca6972b4080498ff202ba /net-analyzer/netperf
parentdev-python/pytest-lazy-fixture: Fixtures in pytest.mark.parametrize (diff)
downloadgentoo-738f0a65389a1d424a80f6e622d84da62c68ab46.tar.gz
gentoo-738f0a65389a1d424a80f6e622d84da62c68ab46.tar.bz2
gentoo-738f0a65389a1d424a80f6e622d84da62c68ab46.zip
net-analyzer/netperf: Set CFLAGS=-fcommon
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706694 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/netperf')
-rw-r--r--net-analyzer/netperf/netperf-2.7.0-r2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-analyzer/netperf/netperf-2.7.0-r2.ebuild b/net-analyzer/netperf/netperf-2.7.0-r2.ebuild
index bc9406377f40..86849c8d0dd7 100644
--- a/net-analyzer/netperf/netperf-2.7.0-r2.ebuild
+++ b/net-analyzer/netperf/netperf-2.7.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,14 +39,16 @@ src_prepare() {
doc/examples/udp_stream_script \
|| die
- # netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
- # nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
- append-cppflags -D_GNU_SOURCE
-
eapply_user
}
src_configure() {
+ append-cflags -fcommon
+
+ # netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
+ # nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
+ append-cppflags -D_GNU_SOURCE
+
econf \
$(use_enable demo) \
$(use_enable sctp)