summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-12 23:36:36 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:54:35 +0200
commitf061e0c6629202ac5da84d601747daa3006700da (patch)
tree7523fdf34a23e120105c26c6b1da428fcfd75359 /net-analyzer/netperf
parentnet-analyzer/arpwatch: drop old version (diff)
downloadgentoo-f061e0c6629202ac5da84d601747daa3006700da.tar.gz
gentoo-f061e0c6629202ac5da84d601747daa3006700da.tar.bz2
gentoo-f061e0c6629202ac5da84d601747daa3006700da.zip
net-analyzer/netperf: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781350 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-analyzer/netperf')
-rw-r--r--net-analyzer/netperf/netperf-2.7.0-r3.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-analyzer/netperf/netperf-2.7.0-r3.ebuild b/net-analyzer/netperf/netperf-2.7.0-r3.ebuild
new file mode 100644
index 000000000000..93441fc7cb54
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.7.0-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Network performance benchmark"
+SRC_URI="ftp://ftp.netperf.org/${PN}/${P}.tar.bz2"
+KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
+
+HOMEPAGE="http://www.netperf.org/"
+LICENSE="netperf"
+SLOT="0"
+IUSE="demo sctp"
+
+DEPEND="
+ acct-group/netperf
+ acct-user/netperf
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-scripts.patch
+ "${FILESDIR}"/${PN}-2.6.0-log-dir.patch
+ "${FILESDIR}"/${PN}-2.7.0-includes.patch
+ "${FILESDIR}"/${PN}-2.7.0-space.patch
+ "${FILESDIR}"/${PN}-2.7.0-inline.patch
+)
+
+src_prepare() {
+ # Fixing paths in scripts
+ sed -i \
+ -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
+ doc/examples/sctp_stream_script \
+ doc/examples/tcp_range_script \
+ doc/examples/tcp_rr_script \
+ doc/examples/tcp_stream_script \
+ doc/examples/udp_rr_script \
+ doc/examples/udp_stream_script \
+ || die
+
+ default
+}
+
+src_configure() {
+ append-cflags -fcommon
+
+ # netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
+ # nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
+ append-cppflags -D_GNU_SOURCE
+
+ econf \
+ $(use_enable demo) \
+ $(use_enable sctp)
+}
+
+src_install() {
+ default
+
+ # Move netserver into sbin as we had it before 2.4 was released with its
+ # autoconf goodness
+ dodir /usr/sbin
+ mv "${ED}"/usr/{bin,sbin}/netserver || die
+
+ # init.d / conf.d
+ newinitd "${FILESDIR}"/${PN}-2.7.0-init netperf
+ newconfd "${FILESDIR}"/${PN}-2.2-conf netperf
+
+ keepdir /var/log/${PN}
+ fowners netperf:netperf /var/log/${PN}
+ fperms 0755 /var/log/${PN}
+
+ # documentation and example scripts
+ dodoc AUTHORS ChangeLog NEWS README Release_Notes
+ dodir /usr/share/doc/${PF}/examples
+ # Scripts no longer get installed by einstall
+ cp doc/examples/*_script "${ED}"/usr/share/doc/${PF}/examples || die
+}